Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I go into settings -> Power Management, trying to change the "Put display to sleep when inactive for:" and "Dim display when idle" settings. The changed settings are saved -- if I come back to the same menu, they appear as I left them.

But when I watch a full screen video, the display does get dim every once in a while. And if I leave my laptop alone for 15 minutes, the screen does go black (and lock itself).

How can I actually change these settings? I would also want to stop it from locking itself every time it went inactive -- just blank the screen.

share|improve this question

2 Answers 2

Workaround

Caffeine is a program that does what you want power management to-do.

You can install caffeine by adding the ppa. you can do that in

System --> administration --> Update manager --> settings --> then tap the "other sources" tab --> add

ppa:caffeine-developers/ppa

And now press the reload button.

or you can do it in a terminal:

sudo apt-add-repository ppa:caffeine-developers/ppa
sudo apt-get update

Then install caffeine by typing in a terminal:

sudo apt-get install caffeine

Power mangament

But you could also try to set the Power management settings as system default by pressing "make default", that worked for me in 11.04 and 10.04.1.

my settings!

share|improve this answer
    
caffeine doesn't seem to want to run -- when I try running it from the command line, it gives me some sort of python-related error. "Make Default" did nothing whatsoever. –  Daniel Aug 7 '11 at 16:51
    
what error did you get? Mine works perfectly! you need to give me more information to help you better. :) –  Alvar Aug 8 '11 at 7:30
    
It's working now that I've restarted... But... It just turns off my power management options. I don't want ot turn them off. I just want to change them. =/. –  Daniel Aug 8 '11 at 13:58
    
What caffeine does it that it let you watch a movie and your computer wont fall to sleep. There are settings in the menu if you click the icon in the panel! –  Alvar Aug 8 '11 at 16:55
    
Well... It doesn't solve my problem. Actually, it doesn't even solve a symptom. I wasn't complaining that my computer falls asleep. The screen just goes idle. And that's only one of the symptoms. I need to be able to change the settings Ubuntu thinks it offers. –  Daniel Aug 9 '11 at 0:28

You said after "15 minutes the screen does go black," so it sounds to me like you're looking for the screen settings:

Ubuntu 11.10 screen settings

To get there, go to System Settings and click on Screen. That's where you can change whether your monitor dims, and whether the screen turns off after a given duration.

share|improve this answer
    
Exactly the answer I was looking for. This screen is currently called "Brightness and Lock". –  Samik R Aug 26 '12 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.