Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to dual-boot UBuntu and Windows 7 on the same 1TB Sata hard drive, but the Ubuntu installer won't recognize the drive- the live CD will, though, and can see it under GParted, etc.

Already tried going into BIOS and changing away from IDE. No luck.

This is OP- I think I was mistaken about what was going wrong. I meant that the installer itself won't recognize the hard drive, but when I use Ubuntu from the live CD, I'm able to see the hard drive, edit it with GParted, even open files from the windows partition.

But, when the installer gets to the step "Allocate Drive Space", it has nothing there- no devices, no partitions, nothing.

share|improve this question
What do you mean by "Ubuntu installer won't recognize", and "live CD will", they are not the same? – enzotib Aug 6 '11 at 22:07
I think what he means is he can mount then disk through nautilus but can't install to the disc because the installer is not seeing it. – TheXed Aug 7 '11 at 3:17
I mean when I run Ubuntu from the live CD, I can see the hard drive, files, etc; but when I try to install, the installer doesn't seem to recognize it, or at least isn't able to deal with the partitions (GParted can, oddly enough) – FreakyCheeseMan Aug 7 '11 at 22:14
up vote 4 down vote accepted

Boot up into your LiveCD as normal. Before running the installer open up a terminal and type in the following command :

sudo apt-get remove dmraid

Dmraid is known to stop some hard drives being detected in the installer. Removing (uninstalling) it solves the problem.

To open terminal on Ubuntu 12.04: ctr + alt + T.

share|improve this answer
Thank you, thank you, lord in Heaven, laughing Buddha, that lion from Narnia, thank you. You are a wise and noble man, and were I to have daughters, you could take any three of them in marriage. That actually worked, and I cannot tell you how long I've been beating my head against this problem- this latest round was the third time I've tried to install Ubuntu on this machine, having given up in frustration twice before. Thank you. – FreakyCheeseMan Aug 11 '11 at 5:44
You're most welcome. I have this problem with one of my hard drives. Tracking down the solution took a ridiculous amount of searching and messing about. It's got nothing to do with a drive's health, btw. Just seems to be a quirk in dmraid. It just doesn't seem to like certain drives and stops the installer from doing it's job. I think you only need dmraid when doing fake-RAID installations, but don't quote me on that. – Don-Megatron Aug 12 '11 at 11:10

open desktop with liveCD. open terminal, write these command and post the output

sudo -i
fdisk -l


Your partition health is not good [hard disk is ok]. Ubuntu does not recognize your partitions but should detect hard disk. "Partition 1 does not end on cylinder boundary" here is one problem in windows partition. I think you partitioned your new hard disk with window 7 [never do this].

safe solution is, delete all your partition and create new with gparted live or partition magic or windows xp or ubuntu. Always remember, keep 1st partition for windows. otherwise windows will not be installed.

alternative solution is, try to install ubuntu as 'inside windows' . install ubuntu in windows as a software . [google ubuntu inside windows].

Note: If you do partition with windows xp or ubuntu then need not install full os. when create partition complete just restart on half way. For dual boot, install windows first then ubuntu.

share|improve this answer
what is your ubuntu version? – shantanu Aug 7 '11 at 7:51
Disk /dev/sda: 1000.2 GB, 1000204886016 bytes 255 heads, 63 sectors/track, 121601 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x08de4925 Device Boot Start End Blocks Id System /dev/sda1 * 1 13 102400 7 HPFS/NTFS Partition 1 does not end on cylinder boundary. /dev/sda2 13 59835 480516096 7 HPFS/NTFS /dev/sda3 59836 121601 496135395 0 Empty – FreakyCheeseMan Aug 7 '11 at 17:27
Redid partitions repeatedly, and tried with several variations (formatted, unformatted, one big windows partition, etc.) The only thing I never changed was the one 100MB partition, cause I didn't want to mess up Windows. – FreakyCheeseMan Aug 7 '11 at 17:29
The original partitions were done for me when I got the computer. But, when you say "Safe"... I assume that step would require me to back up everything on the computer, and re-install windows after getting ubuntu up? Or do you mean that I should leave the first partition intact? – FreakyCheeseMan Aug 9 '11 at 17:05
you have to backup your data, create 1st partition as primary, do not install ubuntu in 1st partition otherwise you can not install windows. – shantanu Aug 12 '11 at 18:03

Make sure you do not have the disc mounted before trying to install. If you have the disc mounted (able to see/open files) then you will not be able to install Ubuntu to that disc as the installer will not be able to write changes to it.

share|improve this answer
Double-checked; drive is unmounted, but still not giving me any options. – FreakyCheeseMan Aug 7 '11 at 6:00

Have you tried booting into the LiveCD, checking if the drive is available (mount it and then unmount it) and then run the installer from the LiveCD itself (the Install Ubuntu Shortcut on the Desktop)?

share|improve this answer
Yeah, same thing happens. – FreakyCheeseMan Aug 7 '11 at 17:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.