Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since I installed my graphics card - a AMD Radeon HD 6850 - I couldn't get Ubuntu to work. I've just installed Ubuntu again but still no success to run it properly. I've installed using updates and MP3 codecs.

When I start Ubuntu, I see the monitor is slipped right. How can I solve this issue?

share|improve this question
Your monitor will have controls to move the screen image left and right - have you tried this? – fossfreedom Aug 6 '11 at 19:02
install the propietary drivers and set the correct overscan – Uri Herrera Aug 6 '11 at 22:18
Are you using the jockey-gtk to install the graphics drivers? If not then try that and let us know. – Abhijeet Aug 7 '11 at 5:00
All of your responses don't meet with my problem. I see the monitor slipped right but I'm able to login, only login. After login operation, the screen freezes and nothing is happening. – onderbakirtas Aug 9 '11 at 13:53
@Abhijeet How can I install while I'm on login screen? – onderbakirtas Aug 9 '11 at 14:00

I had the very same problem with the very same HD6850. Here's what to do:

  1. Boot from LiveCD.
  2. Mount your hard drive by clicking it from Home folder for example.
  3. In a terminal, run:

    sudo gedit /media/hddUUIDcode/etc/default/grub

    (where hddUUIDcode - unique code of hard drive where Ubuntu installed). Hereby you've opened the grub file of the installed Ubuntu.

  4. In the grub file replace the line:



    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=normal noapic"

    Save the changes.

  5. Reinstall grub from a terminal:

    • sudo fdisk -l (Find the partition you want)
    • sudo mount /dev/sda5 /mnt (Mount the partition)
    • sudo grub-install --root-directory=/mnt /dev/sda

    I’ve used the drive /dev/sda and partition /dev/sda5 in my example. Notice the exact spelling.

  6. Reboot and voila...everything works just fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.