Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two W2252TQ Flatron screens, both were working in windows 7 prior to installing Ubuntu 10.04. The active monitor is connected via DVI with the VGA one dark. If I disconnect the DVI one then the VGA monitor becomes the active one. I would like both of them to work.

Additionally if I check the monitors settings it says "Monitory: unknown" with the refresh rate at 50hz. However the monitor seem to be working fine at the right resolution.

I have activated the additional drivers for my NVIDIA graphics card although it says "No proprietary drivers are in use on this system."

What can I do to make Ubuntu handle the second monitor?

Monitor preferences

Additional Drivers Dialogue.

share|improve this question
    
kit - the "driver is activated but not in use" is resolved here - see if this resolves your monitor issues. askubuntu.com/questions/37084/… –  fossfreedom Aug 6 '11 at 17:38
    
Once the "driver is activated but not in use" problem is resolved you should be able to config it in "Nvidia X Server Settings" under "X Server display configuration" (select the non active monitor, then click "Configure..." button and use "Twin View", "OK", "Apply|) –  con-f-use Aug 6 '11 at 17:50
1  
the "driver is activated but not in use" that @fossfreedom mentions in his comment is ussually also solved with a restart. Give it a try and let us know if you succeeded. After which you can check my answer in order to properly configure your monitors. Good luck! –  Geppettvs D'Constanzo Aug 7 '11 at 3:06
    
@fossfreedom - Thanks for pointing out it's a bug in natty. None of the proposed workarounds in that thread (I also read the entire ticket in launchpad) seem to work for me. I'm going to try to install unity-2d and run that until the issue have been resolved. –  Kit Sunde Aug 12 '11 at 10:08
add comment

4 Answers 4

I recently had something similar happen to me.

To resolve it I selected "NVIDIA accelerated graphics driver (version 173)"

After it downloads and installs the driver, you're supposed to restart your computer. I'm fairly certain you won't receive any indications about this.

After your restart your computer, both monitors should display your desktop without your intervention. Will then be up to you to configure.

Cheers!

share|improve this answer
    
So you're saying the issue is resolved in 11.10? The user states in his question this didn't work in 11.04. –  djeikyb Jan 6 '12 at 1:07
    
I'm also on 11.04, so my answer is indeed relevant. ;-) –  Tass Jan 6 '12 at 19:06
add comment

I would suggest you to use the propietary nVidia Settings GUI for that purpose with sudo by dropping the sudo nvidia-settings in a terminal, this way you will be able, (the same as normal way) to set your monitor preferences, in which you can enable both TwinView and Separate X-Screen.

The difference between using sudo in this case is that you may experience an issue when trying to save your preferences to your current X Configuration file, task that can be achieved by hitting the "Save to X Configuration file" in your X Server Display Configuration screen, a screenshot is placed here for your convenience with the Twinview Configuration in action, which in the case of some nVidias may result in an extended desktop instead of a screen clone. (as in my Spakle 9400GT)

Good luck!

enter image description here

share|improve this answer
    
I attempted this, but X wouldn't load after saving so I ended up having to delete the config file it created. –  Kit Sunde Aug 12 '11 at 10:03
add comment

Once I used this "trick" in a friend's computer and it worked, so it's maybe worth trying.

Copy the Bus ID from your graphic card and input it into your xorg.conf

lspic | grep VGA

The output will be something like that

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)

So, copy the Bus ID from your graphic card, in this sample 00:02.0

Back to the console type:

sudo gedit /etc/X11/xorg.conf

Go to the section "Devices" and add the line below, but in the Bus ID you have to replace the last dot "." for a ":"

Busid "PCI:00:02:0"

Remeber, 00:02:0 and not 00:02.0 ;-)

I hope it helps.

share|improve this answer
add comment

I could not get twinview working after initial install either. I switched from Nvidia (Recommended) to Post Release driver with no luck, even after running sudo nvidia-xconfig, sudo nvidia-settings.

Then I switched back to Nvidia Recommended driver, Reboot. In terminal: sudo nvidia-xconfig, then sudo nvidia-settings. Chose 2nd monitor for twinview and setup both monitors accordingly. Now it got weird as the monitor came on, but I lost all frames and keyboard controls. So at this point I did a manual reboot from reset button on my tower, crossed my fingers just for luck and whala !! everything is fine... at least for now it seems.

Oh also before switching drivers back I had also deleted the new xorg.conf file that was created and renamed the orig file back before creating another new one. (hope that makes sense)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.