Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Problem

For an Operating Systems Architecture course at University, we are required to use VMware Player 3.1.4 for class assignments. I currently run 64-bit Ubuntu 11.04, and have recently formatted with a vanilla install of 64-bit 11.04; which still had the following outcome.

I start the install off by cd'ing to the directory where the VMware bundle resides and running this installation command:

sudo sh ./VMware-Player-3.1.4-385536.x86_64.bundle

Unfortunately, after half of a second of running the install script, I encounter this error:

./VMware-Player-3.1.4-385536.x86_64.bundle: line 302: /tmp/vmis.k6Yk9O/install/vmware-installer/vmware-installer: Permission denied

At which the extracted installer is executed at line 302 with the following options:

302     "$installer" --set-setting vmware-installer libconf "$libconf"   \
303                  --install-component "$source"/vmware-installer      \
304                  --install-bundle "$bundle" "$@"

Also, an md5sum called on the bundle returns the exact sum as mentioned on the download page.

a7fdadfb2af8d9f76571cd06f2439041 VMware-Player-3.1.4-385536.x86_64.bundle

At this point, I've used sudo -i to log in as root which still throws a permission denied error.
Searching Google and Stackoverflow provided only one other case with no answers (I upvoted); so I decided to post to askubuntu wondering if somebody has had the same issue or has a fix under 11.04?

Cheers! :P

share|improve this question
2  
Alex - the partition that holds your /tmp folder, does it have a "noexec" in /etc/fstab - I think that may cause this issue. –  fossfreedom Aug 6 '11 at 15:54
    
Haha, oh man... You must be dead on the head with this one... Yeah, I've mounted my /tmp to ram using nodev,nosuid,noexec,mode=1777 - I'll boot up my 64-bit and try it out :P –  Alex Stevens Aug 7 '11 at 14:07

1 Answer 1

up vote 7 down vote accepted

It is likely that the installer is trying to execute a binary in the /tmp folder.

It is probable that whatever partition you have your /tmp folder in, it is configured in /etc/fstab to be "noexec". This means that no binaries are allowed to be executed on that partition.

My advice is to move /tmp to its own partition that has "exec" rights in your fstab line options.

Alternatively, temporarily change "noexec" to "exec" in fstab - install vmware and then switch it back again.

share|improve this answer
    
Perfect! Thank you very much @fossfreedom, I'll notify the other fella over at Stackexchange :P - Although, it's already been answered there for you by another chap. –  Alex Stevens Aug 8 '11 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.