Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After removal of gnome-3, I am not able to install any gnome applications like gedit, gnome-control-center, I am getting following error. How to solve this?

sunny@sunny-TravelMate-4740:~$ sudo apt-get install gnome-control-center -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-control-center : Depends: libappindicator1 (>= 0.2.96) but it is not going to be installed
                        Depends: libatk1.0-0 (>= 1.12.4) but it is not going to be installed
                        Depends: libcanberra-gtk0 (>= 0.2) but it is not going to be installed
                        Depends: libdbus-glib-1-2 (>= 0.78) but it is not going to be installed
                        Depends: libebook1.2-10 (>= 2.32.2) but it is not going to be installed
                        Depends: libgconf2-4 (>= 2.31.1) but it is not going to be installed
                        Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
                        Depends: libglib2.0-0 (>= 2.24.0) but it is not going to be installed
                        Depends: libgnome-desktop-2-17 (>= 1:2.29.92) but it is not going to be installed
                        Depends: libgnome-menu2 (>= 2.27.92) but it is not going to be installed
                        Depends: libgnome-window-settings1 (= 1:2.32.1-0ubuntu15) but it is not going to be installed
                        Depends: libgnomekbd4 (>= 2.31.5) but it is not going to be installed
                        Depends: libgtk2.0-0 (>= 2.20.0) but it is not going to be installed
                        Depends: libmetacity-private0 (>= 1:2.26.0) but it is not going to be installed
                        Depends: libpango1.0-0 (>= 1.17) but it is not going to be installed
                        Depends: librsvg2-2 (>= 2.26.0) but it is not going to be installed
                        Depends: libunique-1.0-0 (>= 1.0.0) but it is not going to be installed
                        Depends: libxklavier16 (>= 5.0) but it is not going to be installed
                        Depends: libxss1 but it is not going to be installed
                        Depends: capplets-data (>= 1:2.32.1-0ubuntu15)
                        Depends: capplets-data (< 1:2.33)
                        Depends: gnome-settings-daemon (>= 2.30) but it is not going to be installed
                        Depends: gnome-menus (>= 2.12.0) but it is not going to be installed
                        Depends: gnome-icon-theme (>= 2.24) but it is not going to be installed
                        Depends: desktop-file-utils but it is not going to be installed
                        Depends: gconf2-common (>= 2.23.2-0ubuntu3) but it is not going to be installed
                        Depends: ubuntu-system-service (>= 0.1.10) but it is not going to be installed
                        Recommends: evolution-data-server but it is not going to be installed
                        Recommends: gnome-user-guide but it is not going to be installed
                        Recommends: gnome-session but it is not going to be installed
                        Recommends: policykit-1-gnome but it is not going to be installed
                        Recommends: mousetweaks but it is not going to be installed
 libaccess-bridge-java : Depends: default-jre but it is not going to be installed or
                                  openjdk-6-jre but it is not going to be installed or
                                  sun-java6-jre but it is not going to be installed
                         Recommends: libaccess-bridge-java-jni but it is not going to be installed
 libglu1-mesa-dev : Depends: libgl1-mesa-dev but it is not going to be installed or
                             libgl-dev
share|improve this question
1  
But of course you can't you have to completely reinstall Gnome 2. –  Uri Herrera Aug 6 '11 at 10:08
add comment

1 Answer 1

As stated by Uri Herrera in the above comment all these packages depend on having a version of gnome installed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.