Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im currently using fglrx from AMD and wanna try other driver to see if I can get better performance with compiz (I'm getting flickering). Everything I've tried dont works(Radeon, RadeonHD), I think that 6770 is too new; But wait! 6770 is almost identical to 5770! Any idea? I have ubuntu 11.04.

share|improve this question
    
Go to CCSM (compiz Configuration Settings Manager) then go to the OpenGL plug in and then uncheck Sync to Vblank. Then go back and on the Composite plug in uncheck Detect Refresh Rate –  Uri Herrera Aug 6 '11 at 4:25
    
@UriHerrera you should post that as an answer. –  Thomas W. Aug 7 '11 at 13:48
add comment

3 Answers

Go to CCSM (compiz Configuration Settings Manager) then go to the OpenGL plug in and then uncheck Sync to Vblank. Then go back and on the Composite plug in uncheck Detect Refresh Rate

share|improve this answer
add comment

It is unlikely you will get better performance with the open-source driver. Fglrx is much more efficient, so it will result in smoother graphics, more FPS in games etc. There are some exceptions, though, the open-source driver supports KMS while fglrx not, so with fglrx you will not get a pretty ubuntu logo while booting-up your system.

share|improve this answer
    
That just isn't true. I'm using a HD5850 and the open driver is much more stable and much faster. –  Jo-Erlend Schinstad Aug 7 '11 at 15:39
add comment

The open driver has improved significantly over a very short time. If you want to get a feel of how it's progressing, then you might want to fire up Oneiric Alpha 3 and run it live. My experience is that the driver in Oneiric is much better than the one in Natty. Other issues with Oneiric forced me back to Natty, but the improvements in graphics alone makes me want to upgrade as early as I can.

share|improve this answer
    
jo-erlend - if you also want to test newer drivers on Natty, you could always try the x-swat ppa - or the bleeding edge x-edgers ppa. –  fossfreedom Aug 7 '11 at 16:08
    
The open source drivers in Oneric does not work for me at the moment at all, the X server won't start properly... –  Rafał Cieślak Aug 7 '11 at 19:55
    
No, but then Oneiric isn't released yet either. The driver works properly. I'm not guessing. I've tested this. The driver works. X doesn't. –  Jo-Erlend Schinstad Aug 8 '11 at 14:49
    
@jo-erlend: It does not matter whether it's X issue or the driver's. The point it that you won't get ANY graphics at the moment. This may mean that some people will be unable to use the driver in Oneric (at the moment). –  Rafał Cieślak Aug 15 '11 at 19:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.