Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After getting Ubuntu setup on my Macbook Pro with Gnome Shell, there is one little thing irritating me:

I have an external monitor connected which is set as primary in the Nvidia control panel. I'd like that if the lid of the Macbook is closed, the internal display is disabled completely, if it's opened, it enables twinview.

I've found the configuration settings for lid closing in Gnome Tweak Tool, but the best I can make it do is blank the screen, but that still means my desktop extends onto the Macbook.

share|improve this question

Not sure if your problem is Macbook specific. If it isn't, you can just go to power settings, and specify the Do nothing option when the lid is closed.

Then you can open Displays, and turn your laptop screen off. See below:


share|improve this answer

I had this same problem on my 6.2 MBP. It has an nVidia card. If your using an ATI model then I am not sure.

First reset your NVRAM and SMC just to make sure your not having issues left from installing or setting from OS X, or anything like that. Keep in mind that neither of those should be done too often, but once in a while doesn't hurt, and because linux doesn't "store" any of it's configuration there it should be fine. Remember OS X will have some settings reset.

Next make sure you install nvidia-experimental-304 or better. Earlier versions did not detect monitor hot plugs over the display port (for me).

Remember that all the "Mac" rules still apply. You can not close your lid on battery and have the laptop stay on, no matter what you do.

Now for configuration. Go to System Setting then power management and make sure to disable suspend when lid is closed and on power. Might as well leave it active on battery as nothing is going to stop that.

Now make sure you have a keyboard attached and close your lid. Your laptop screen will go black as will your external monitor. Press a button and your monitor will go on (this is a hardware feature OS X does this as well).

share|improve this answer

Just go to your "Dash Home," type in "Displays", click on "Displays" icon , then select the display which you want to use. Use the Switch button to switch your display on or off.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.