Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed Kubuntu, and I notice that Dolphin tries to access SMB shares using libsmbclient instead of mounting an SMB location like I am used to in Nautilus. Unfortunately, the performance is horrendous, and for some reason, I am unable to access shares that I could access in Nautilus (it gives me authorization issues which I didn't have in the SMB mounts).

Is there a way to mount SMB shares in Kubuntu as in Ubuntu?

(Note: I am accessing the share over a VPN, in case that makes a difference, but I don't see why it should, and in Nautilus the performance was completely accetable).

share|improve this question
up vote 3 down vote accepted

Try using command line tools like smbmount. This will mount the dir, KDE or Gnome , you will always be able to mount. Eventually you can put it into /etc/fstab, but when starting up without network or connected to another network the mount will not succeed.

share|improve this answer
    
Thanks for the answer. I should probably rephrase my question, because I actually want mounting of an SMB share in the file manager (Dolphin) in the same way that it works in Nautilus. For now I will +1, but I will accept your answer otherwise and perhaps post a more specific question after. Thanks again. – mydoghasworms Aug 5 '11 at 11:39

The Dolphin, and Konqueror file manager/browsers both support cifs. Just input "smb://my_windows_server/my_share_name/" or "smb://myuser@my_windows_server/my_share_name/" in the url field. With dolphin the bar is hidden, but you can open it by clicking on network in the side bar or clicking after the icon for your current location.

PS- Smbmount is not really used in modern linux systems. If you want to mount the filesystem the example using cifs tools is more likely to work.

share|improve this answer

Possible solution:

  1. Create /media/MOUNTPOINT
  2. Install cifs-tools package
  3. Add to fstab the line:

    //IP_SAMBA_SERVER/SHARE /media/MOUNTPOUNT cifs user,noauto,user=smb_username,password=smbpasswd 0 0
    
    • After that, it will appear a new icon in Dolphin with MOUNTPOINT name. By clicking on it, it will mount the SMB share.
    • NOTE: For security reasons, may be better to use the option "credentials" instead user & password. Check man mount.cifs to learn how to use it.
share|improve this answer

This question is old but the problem still applies to users who have the same problem with the current kUbuntu 14.04 LTS.

You can use Smb4k

Application pic

I did the following in a fresh install of kUbuntu 14.04.4 LTS

sudo apt-get install smb4k
  1. Go to application launcher and type smb4k, then click or enter to run.

  2. Click on the tab at the bottom left that says “Network Neighborhood”

  3. Browse for your network shares (windows, smb/samba, etc). My shares are username/password protected so when I tried to access them, it prompted me for login details and after entering them the shares were automatically mounted.

  4. After it’s mounted, you can use the default file manager (Dolphin) to browse, access files, play movies, etc.

More info on Smb4k at kde-apps.org, userbase.kde.org/Smb4K or go to docs.kde.org and type smb4k in application name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.