Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Fujitsu laptop and all was working fine until I ended teamviewer. On the keyboard it has a numberpad on some of the letters which you press the Fn button to use. The system is acting like I have the Fn key pressed and I get numbers shown when it should be letters. If I press the Fn key the numbers go to letters. The Fn key is not stuck down. Is there a way to reset keyboard settings or a known fix. The operating system is Ubuntu 11.04 Natty.

share|improve this question
    
thanx is the numlock turn on i turned off and keyboard work fine agine –  user52619 Mar 29 '12 at 17:34
add comment

6 Answers

up vote 5 down vote accepted

The Fn key is generally handled via the ACPI BIOS rather than directly by the operating system, so there is unlikely to be anything that Ubuntu itself can do.

One possibility is that you've turned on the NumLock, which might cause those keys to default to numbers instead of letters. Hitting the key (or key combo: on my laptop Number Lock is toggled by the Fn+ScrLk key combo) again should set things back to normal.

If that doesn't work, restarting the system will probably return it to the default state.

share|improve this answer
    
Thank you for your help. –  Matt Aug 8 '11 at 11:38
add comment

My girlfriend's laptop (Asus EEE 10") had this exact problem; pressing the numlock key (which required the fn key in this case) fixed it.

The interesting thing though, is that before I figured it out, the problem persisted after reboots, but only happened in her user. So apparently Ubuntu saves the numlock state (per user) across reboots. It's an old version (10.04) so I don't know if this is still the case, but there you have it.

share|improve this answer
add comment

On samsung laptop, there are "Fn Lock" button on right-top of the keyboard so that it fixed.

share|improve this answer
    
On Lenovo it is on the Esc key. I.e. Fn + Esc toggles the behaviour of the Fn key. (BTW, same behaviour in Windows; I could find nothing in the bios.) –  Darren Cook Mar 29 at 13:26
    
So it can be different way on different vendors :-) –  Romy Prazhad Apr 8 at 10:08
add comment

For me, I had only to press Fn with F11. This combination enable/disable the num lock in notebook keyboard!

Otherwise you can try another combination in your keyboard to enable/disable num lock.

share|improve this answer
add comment

I found that the Num Lock is the issue here. I had the same issue, and I turned off num lock and it worked fine for me after. It's because that's what registers as a normal number pad, and instead of hitting Fn, num lock automatically replaces the Fn key.

Its a derp, but fixable easily.

share|improve this answer
add comment

I was having trouble with this.. Turns out there was a Fn-lock-button on my keyboard up by F12... silly me missed it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.