Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install Ubuntu on my Shuttle SS30g2 the video has vertical lines down it that show a different part of the screen. I'm at my wits end how to fix it. I have a SS30g1 and it shows the same video corruption.

Corrupt video display when running Ubuntu

The lspci output for the onboard video is:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter (rev 04) (prog-if 00 [VGA])
    Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Unknown device 3079
    Flags: 66MHz, medium devsel, IRQ 5
    BIST result: 00
    Memory at d8000000 (32-bit, prefetchable) [size=128M]
    Memory at fdae0000 (32-bit, non-prefetchable) [size=128K]
    I/O ports at cf00 [size=128]
    Capabilities: [40] Power Management version 2
    Capabilities: [50] AGP version 3.0

The annoying thing is that with old versions of Ubuntu/Mythbuntu (6.06, 6.10) the display works fine. I would use 6.06 but the partition manager won't work. With 7.04 or 7.10 (don't remember exactly) the corruption starts and all versions up to 11.04 (inclusive) have corrupt video.

Any help you could give would be great!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

SIS Graphics for a very long time have been poorly supported under linux.

Various workarounds have been suggested - here are mine.

During boot from your live CD - choose (or add) xforcevesa to your boot option. If necessary, also add nomodeset as well. N.B. press space when the purple screen with the strange icon at the bottom of the screen is display during the boot from the live CD. Then press F6 to edit your boot options.

This (or these) boot option(s) should give you a low resolution but usable display.

Once installed, you can try the following:

workaround 1 Try forcing the use of the sis driver in your xorg.conf

  • gksu gedit /etc/X11/xorg.conf
  • If the file opened is empty copy and paste the following - otherwise just make sure Driver "sis" in the Device section is specified.

workaround 2 - If this still doesnt work then change Driver "sis" to Driver "vesa" to use the standard vesa graphics.

workaround 3

This suggestion should be carried out with a Driver "sis" in your xorg.conf file.

Press ALT + F2 and login:

  • gksu gedit /etc/modules
  • The editor will open. Add the following as a new line to the bottom: sisfb

Reboot - this should hopefully give you a usable display.

xorg.conf

Section "Device"
Identifier "Video Device"
Driver "sis"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
EndSection
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Video Device"
EndSection
share|improve this answer
    
Thank you! Setting it to "sis" did not work, but using "vesa" works! –  Jerry Seutter Aug 5 '11 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.