Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, with the exception of StarCraft I, every game I've installed with with Wine will not run (I've tried C&C 3, Worms Armageddon, and Rome Total War). All the games install fine, but when I try to run them (from the winefile), the screen flickers a bit (like it's trying to close out winefile) and then stops. And when I exit out of the winefile it looks like it has reverted my version of Ubuntu back to 10.08 (I think, the one I currently have is 11.04).

This is driving my crazy, as I cannot get any game (with the exception of StarCraft, and even then, the sound doesn't work) to work. Does anyone know how to fix this? Thanks!

share|improve this question
1  
wine is not so powerful to run max of game. try playonlinux or Cedega. Cedega is not free –  shantanu Aug 4 '11 at 16:22
    
If I can't get this to work, then I might try one of those. However, would the fact that I have /home on a different partition have anything to do with this? –  Wolf Aug 4 '11 at 16:26
    
/home is not problem. Do you have external graphics card ? try to run any windows application (software) which will test wine. –  shantanu Aug 4 '11 at 16:30
    
No, I don't have an external graphics card. I tried running Rome Total War and this is what came up in the terminal: fixme:ddraw:DirectDrawEnumerateExA flags 0x00000003 not handled X Error of failed request: GLXBadDrawable Major opcode of failed request: 128 (GLX) Minor opcode of failed request: 5 (X_GLXMakeCurrent) Serial number of failed request: 536 Current serial number in output stream: 536 –  Wolf Aug 4 '11 at 17:15
    
POL uses WINE, and so does Cedega, with Vanilla Wine you need to tweak it further, if you use POL it uses a Wine version that runs the game you want, i.e. Game A no longer works in 1.3.25 but works on version 1.1.x, so POL downloads a file containing that version. –  Uri Herrera Aug 4 '11 at 17:24
show 2 more comments

2 Answers

up vote 3 down vote accepted

First of to help you i need some more information:

  1. Have you checked AppDB from Wine if these games are running fine ? see: http://appdb.winehq.org/objectManager.php?sClass=application&iId=1308

As you can see it is gold rated so it should work. Also the version who is gold rated is the latest wine (1.3.25).

  1. Do you have the latest version of wine?

  2. Do you have the same version of the games who are reported to work in appdb ?

  3. Do you have your real graphics driver installed (fglrx or nvidia) and not those shitty oss drivers (I mean you just can play with the oss driver, its just reality)

  4. Did you follow the instuctions on the wine page? (in AppDB) for install and startup etc.... (Howto)

  5. How do you start the games ? Please post your commands..

  6. Also i would not recommed using some gui to start the games, you cant see the console output with my leads to the clue of some missing dlls....

UPDATE:

  1. I forgot to ask: Do you have the games installed in a separate wine prefix for each game ? if not -> you should do...

Thanks

M.

Update 2:

  1. Go to: http://www.winehq.org/download/ubuntu or https://launchpad.net/~ubuntu-wine/+archive/ppa and get the newest version. They are stable!

  2. Put this into an console: "glxinfo | grep vendor" it should put out nvida or ati and NOT mesa

  3. The istrucions are in the appdb from wine normaly on one of the versions. for Armagedon they are here: http://appdb.winehq.org/objectManager.php?sClass=version&iId=1744 (scroll down a bit)

  4. Well this is not the way you should start your games. you cant read any warnings and im not sure if it is corretly loaded anyway. The correct (working) way for me is:

cd /path/to/game WINEPREFIX=/Path/to/Prefix wine Game.exe

For more info about Wineprefix see: http://wiki.winehq.org/FAQ#head-faf9617c53607e583f6e6ff70a4ac9522d490faf

share|improve this answer
    
I would just like to note that the "shitty" OSS drivers would actually be better to install while you're initially trying to get it to work. The "real" drivers often far more buggy and those drivers themselves may need to be tweaked. –  user606723 Aug 4 '11 at 17:37
    
The 3D performance of the OSS drivers vs the Propietary ones, just can't be compared. And most errors like the ones the OP is having with Wine are related to Wine's DirectX Implementation. –  Uri Herrera Aug 4 '11 at 17:42
    
1 - No, I have 1.2.2 2 - Yeah, I have RTW Gold edition (which I think is rated platinum) 3 - I think so, but possibly not, how would I check that? 4 - Where are the instructions 5 - winefile, then I browsed to the game.exe and ran it (I've tried cd to the game's folder in /.wine/... but it would say that the it could not find RomeTW.exe in windows//system32//). Also, how do you add line breaks? –  Wolf Aug 4 '11 at 17:42
    
Wolf please post another answer and not in the comments, i cant read it there very well... –  Manuel Aug 4 '11 at 17:44
    
Sorry, it won't let me post another answer. But, if you tell me how to add line breaks to a comment, I can edit my comment. –  Wolf Aug 4 '11 at 17:50
show 10 more comments

The error message clearly says

fixme:ddraw:DirectDrawEnumerateExA flags 0x00000003 not handled

I.e. wine's implementation of DirectX can not yet handle a certain combination of flags passed to a routine by the game. Try everything Manuel says, then try installing native (Windows-native, that is) DirectX libs using winetricks.

share|improve this answer
    
Okay, thanks, I'll try that. –  Wolf Aug 5 '11 at 13:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.