Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed kubuntu 11.04 and first it downloaded and installed packages fine but after a few time it cant download the packages and it says:"connection has timed out" I already tried to unplug and plug my moden but it didnt work do you have any ideas how to fix this?

share|improve this question
seems like a network issue, can you surf the net with your browser? – Dirk Hartzer Waldeck Aug 4 '11 at 16:13
Yes, I can surf the net. – Eitan Fishman Aug 4 '11 at 17:31
up vote 2 down vote accepted

1) As A GENERAL fix, try connecting to the Internet and opening a Terminal then, try the following commands on at a time.

sudo dpkg --configure -a 
sudo apt-get -f install 
sudo apt-get --fix-missing install 
sudo apt-get update 
sudo apt-get dist-upgrade 
sudo apt-get clean 
sudo apt-get autoremove
sudo apt-get update

Does it work? Does it stop? At what point does it stop and what error message does it give?

2) Try changing your Repositories to the quickest. (This can almost change day to day, so it needs to be watched.)

Go Synaptic Package Manager>Settings>Repositories>then, where it says "Download From" change to "Other"> Choose Select Best Server

share|improve this answer
Thanx,I selected best server and now it is working although the download speed is slower then what I used too I guass there are some problems with the usual server and I hope it will be fixed soon. – Eitan Fishman Aug 4 '11 at 16:32
You should try to find a mirror close to you. Many universities provide mirrors with really nice speeds. If you're not maxing out your internet or getting at least 1MB/s, you should find a better mirror. – user606723 Aug 4 '11 at 18:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.