Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does anyone know how to ensure that my mouse is recognized on startup? I have to physically unplug and re-plug the mouse in order for it to work again.

share|improve this question
up vote 4 down vote accepted

That might be because of the port you are using. I heard that some ports are supposed to be reserved for keyboard/mouse. If you use a different port, like the one at the back instead of the front), this may help. I know that Windows has issues if I change the mouse to another port while it runs. and if I change to another port, it may not be detected at all as Windows starts, although Ubuntu will detect it no problem.

BTW: Try to avoid hubs for keyboard and mouse.

share|improve this answer
Thanks. I got the mouse working on startup by plugging the mouse into a USB port higher up in the tower. Perhaps it's a set of ports that have higher priority? – user20635 Aug 4 '11 at 21:50

On motherboards Asus M2N I've found that this problem is corrected on BIOS by turning usb to auto mode, by default it is enabled. Anyway, some usb HDD attached on PC, may make this way your PC takes too much time (some seconds more) during bootup of system.

share|improve this answer
Thanks, had the problem with my Logitech G35 headset. This resolved it. – Dominic Bartl Dec 31 '14 at 14:11

I found another solution other than replugging the USB mouse. At boot enter your BIOS setup and look for an Integrated Peripherals section. It's counter intuitive, but worked for me. I disabled the USB mouse support entry. I have no idea why this worked but if you have the same problem give it a try, if it doesn't work you can always reset it by entering the BIOS again and changing it back to enabled.

Also see:

share|improve this answer
line does not exist – nkvnkv Jan 5 at 1:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.