Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 11.04, classic desktop. Hardware is working fine, and network was working previously, but after changing my location (and rebooting the machine), Ubuntu just says 'Wired Network Disconnected'. Router shows working connection, and booting to XP gives a working network.

What could I try to fix this?

ifconfig shows eth0 interface with an IPV6 address only.

edit:

eth0      Link encap:Ethernet  HWaddr 00:13:8f:81:88:89  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 Base address:0xe800 

auto lo
iface lo inet loopback

# This file is installed into /etc/NetworkManager, and is loaded by 
# NetworkManager by default.  To override, specify: '--config file' 
# during NM startup.  This can be done by appending to DAEMON_OPTS in 
# the file:
#
# /etc/default/NetworkManager
#

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Okay, new info: ifdown eth0 says

ifdown: interface eth0 not configured

share|improve this question

closed as too localized by Bruno Pereira Feb 24 '12 at 18:58

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Please paste the output of the following 3 commands: sudo ifconfig eth0, cat /etc/network/interfaces and cat /etc/NetworkManager/NetworkManager.conf –  Pavlos G. Aug 4 '11 at 14:03
2  
Also, sudo dhclient eth0 and try to disable and renable networking in NetworkManager. (independent ideas, not sequential) –  user606723 Aug 4 '11 at 14:36
    
ifdown eth0 ; ifup eth0 ; dhclient eth0 ( all as root) may work. Else check your syslog file ( sudo less /var/log/syslog ) may give u an idea why u do not get an IP –  Goez Aug 5 '11 at 8:36
    
I managed to get network connectivity by manually adding the gateway, a known working dns, and the ipv4 address. Network Manager still doesn't show a connection, though. –  Esa Aug 8 '11 at 17:41
    
I suspect this is really a bug in the ethernet driver used. Could you please add the output of ''lspci -vnvn'' –  Mathieu Trudel-Lapierre Nov 2 '11 at 14:38
add comment