Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed an Ubuntu Studio in one of the partitions that I had for using Gnome3.
The Grub2 that was installed by the default Ubuntu Studio changed all the /boot/grub/grub.cfg file creating its own menu.
Till here no problem, everything going normal.
The thing is that it wrote on the grub2 menu the new entry for the Ubuntu Studio kernel and the others SO's (windows and the default Natty with Unity) but it still there the entry for the Gnome3 kernel and it is the Grub2 menu entry for using the Natty-Unity kernel and the Ubuntu-Natty kernel does nothing.
I tried to edit the /boot/etc/grub.cgf file in the Ubuntu Studio and at the Natty-Unity installations and every time that I run sudo update-grub2 it write's back again the old menu entry that the Ubuntu Studio installation did.
I tried also using the Grub-Customizer GUI to change the entry but there is no effect at all when I try to update the Grub2 menu.
Theres any other way that I can fix this problem without having to edit an entry in /etc/grub.d ? Because in the ubuntu forum the explanation how to do it so it's not that clear.
Please Help. Thanks in advance.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

I to am having what seems to be the same issue, and have been having it since the first time grub 2 was implemented. no mater if I run sudo update-grub2/sudo update-grub or use grub customizer to make the changes, no matter what i do they always only update the grub.cfg.new file and not the grub.cfg file, as the last edited date shows.

I read somewhere that GRUB 2 does not deal well with empty entries

https://answers.launchpad.net/grub-customizer/+question/175491

I try to stick it out ever new release and just find myself going back to Grub 1 as it's tried true and just works for my needs . I understand that GRUB 2 is the future and more powerful and then its legacy version, and it really is at least on paper but as far as I am concerned at the present is not ready for prime time. Sorry to not have a fix for you. Just wanted to say you are not alone.

I'll just wait till all the kinks are worked out.

share|improve this answer
add comment

Each installation of Ubuntu will create its own Grub2 menu which will be put in the MBR overwriting the Grub2 menus of the other Ubuntus in their partitions.

So, decide which Ubuntu will be your standard, working Ubuntu and only run sudo update-grub2 on that installation. Have Grub Customizer installed on your standard, working Ubuntu and use the File menu, Install to MBR option.

Kernel updates on the other Ubuntus will generate a new Grub2 menu. So, do your standard, working Ubuntu kernel update last and use Grub Customizer to restore your modified Grub menu back into the MBR. It works for me.

Regards.

share|improve this answer
    
Thanks for your answer. The problem is that doesn't matter what I do in Grub-Customizer, every time that I run sudo update-grub2 it comes back the menu that was generated from the Ubuntu-Studio installation, even if I run from Natty-Unity or from Ubuntu-Studio. Everything that I try to change the menu it comes back to this configuration :( –  fejao Aug 4 '11 at 15:16
    
ubuntu-studio is probably installing to MBR by default and the others not –  Dirk Hartzer Waldeck Aug 4 '11 at 16:18
    
@Dirk Hartzer Waldeck - I already tried updating at BOTH (Studio and regular Ubuntu) but at BOTH I can not change the menu. Does anyone knows if I erase the MBR and with a ubuntu install cd I can repair this? Or any other ideas? –  fejao Aug 9 '11 at 23:19
    
There's two parts that could be getting updated: the /boot/grub/grub.cfg and the MBR which points to the grub.cfg of a specific install. You could be regenerating the /boot/grub/grub.cfg with update-grub but it won't work until the MBR points to it. You can do this with sudo grub-install /dev/sda (assuming sda is the disk you boot from. –  Azendale Oct 20 '11 at 16:11
add comment

I am unsure with Ubuntu Studio, but with Ubuntu you need to edit the default config file:

/etc/default/grub

This file then updates /boot/grub/grub.cfg when you run:

update-grub

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.