Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been searching for a way to disable the "hot corner" feature of the Activities button in Gnome Shell. I would prefer it to require a click such that I don't keep accidentally activating it upon mouse over.

share|improve this question

5 Answers 5

For 11.10

The location of this was changed for 11.04, for 11.04 look below. You can do this with a quick edit of the file /usr/share/gnome-shell/js/ui/layout.js If you find the code:

this._corner = new Clutter.Rectangle({ name: 'hot-corner',
                                       width: 1,
                                       height: 1,
                                       opacity: 0,
                                       reactive: true });

Change reactive: true to reactive: false and it will disable the hot corner but still allow to activate the overview screen by clicking the Activities button or by pressing the Super (Windows) key.

I'm going to look into making an extension to modify this behaviour instead of direct modification of the panel.js file as it will be overwritten with updates.

For 11.04

Same as above but edit the file /usr/share/gnome-shell/js/ui/panel.js:

this._corner = new Clutter.Rectangle({ width: 1,
                                       height: 1,
                                       opacity: 0,
                                       reactive: true });
share|improve this answer

I think there's no option to disable it yet. I like the hot corner, but I hope there will be good configuration tools for Gnome 3 by default.

share|improve this answer
    
Well, I believe there's a way to «delete» it directly from the code, but I don't think that's a good idea. –  Alfredo Hernández Mar 28 '11 at 18:53
1  
There is now an extension that allows configuration -- see my answer below. –  krlmlr Feb 20 '13 at 20:06

Download extension.js and metadata.json from https://github.com/hermanus/gnome-shell-extensions/tree/master/Gnome-shell-activities-hotspot-disabler and put them in ~/.local/share/gnome-shell/extensions/activitieshotspotdisabler@harmus.gmail.com/. The name of the directory is important -- you can change it if you change the uuid in metadata.json too.

This will install an extension that overrides the Panel.HotCorner.prototype._onCornerEntered function, so the activities screen is only shown when you click on 'Activities'. To activate it, visit https://extensions.gnome.org/local/ .

Currently, this extension works with Gnome version 3.6, that's the one shipped with Ubuntu 12.10. If you browse through the history at Github, you will find versions that work with older Gnome releases (up to 3.0. = Ubuntu 11.04.)

share|improve this answer

In 11.10 and later versions, you can disable the hot corner by installing the "No Topleft Hot Corner" extension from the official Gnome-shell extensions site.

share|improve this answer

The Activities configurator extension has an option to disable the "Activities" hotspot. It is called "Disable Hot Corner". Also, by default, the text is replaced by an icon -- this saves space.

Screenshot

Works for Ubuntu 12.10.

share|improve this answer

protected by Community Sep 28 '11 at 17:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.