Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a dual monitor setup and wish to only record the 1st monitor with recordmydesktop, but I am unsure of the settings when doing it via the command line, so far I have this:

recordmydesktop --display=1 --width=1920 height=1080 --fps=15 --no-sound --delay=10

But I get this error message:

Cannot connect to X server 1

How do I find the right X server to connect to and are the rest of my settings correct? I'm using 11.04, cheers.

share|improve this question
I'm guessing but I think the --display=1 should infact be --display=:0 – fossfreedom Aug 3 '11 at 21:04
up vote 6 down vote accepted

You have no need to set the display to 1 since probably you are running a multi- screen setup on the same X server.

The correct command would be:

recordmydesktop --display=0 --width=1920 height=1080 --fps=15 --no-sound --delay=10

Reduce the width and the height parameters if that is including your 2nd screen.

share|improve this answer

Display parameter is irrelevant. Trick is setting coordinates correctly. All screens considered as whole.

Say you have two screens,

primary has 1680x1050 secondary has 1024x768

Your coordinate space is : 2704x1050 ( sum of two screens width and the biggest height )

to capture second screen

-x=1680 < width of primary screen -y=0 < default --width=1024 --height=768

--display=$DISPLAY < in my ubuntu 13.10

The command would be : ( tested on ubuntu 13.10 )

recordmydesktop --display=$DISPLAY --width=1024 height=768 -x=1680 -y=0 --fps=15 --no-sound --delay=10
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.