Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since I reinstalled Ubuntu a few hours ago, I've experienced major visual artifacts with smaller font sizes in Firefox. The fonts end up looking like this:

http://i.stack.imgur.com/BdpiR.png

Or even like this:

enter image description here

This only occurs in Firefox; other applications are unaffected. It also occurred on the LiveUSB I used for installation, making me suspect a hardware or driver issue. The output of lshw on my computer is here: http://pastebin.com/LnSt6veT.

Any idea what might be causing this, or how I can fix it?

... and "Use Google Chrome" is not a valid answer. ;)

share|improve this question
add comment

4 Answers

Have you tried tweaking your font hinting settings in Preferences > Appearances?

Go to the Font tab and click Details... See if a different setting improves the situation.

share|improve this answer
    
I tried that; but none of the settings help. Actually, FireFox doesn't seem to obey most of them. :( –  snostorm Jul 31 '10 at 23:27
add comment

Removing 'msttcorefonts' might also fix it.

share|improve this answer
    
+1, this package is horrible, it makes the font ugly in firefox, I always apt-pin it to prevent it from being installed. –  Weboide Jul 31 '10 at 16:54
1  
That package is not installed. I installed it to test; having it installed changes nothing. :( –  snostorm Jul 31 '10 at 23:31
add comment
up vote 4 down vote accepted

The problem was with the Nouveau driver I was using; for whatever reason it wasn't rendering fonts correctly in FireFox. Switching to the proprietary Nvidia driver fixed it.

share|improve this answer
    
Seems to be weird.. Did you read help.ubuntu.com/community/BinaryDriverHowto/Nvidia –  User Aug 1 '10 at 1:44
    
No, but that's only about the NVidia driver, not about Nouveau. I've had similar weird problems with Nouveau before, though on other graphics cards. –  snostorm Aug 1 '10 at 1:53
add comment

You seem to have managed to solve your problem. Still, if you're referring to a recent bug in Firefox that makes it 'disobey' the system-wide font settings in Ubuntu, this may help you out: http://www.uluga.ubuntuforums.org/showpost.php?p=8193420&postcount=11.

In short, the bug makes Firefox always render website fonts (and its chrome GUI fonts) anti-aliased (AA). The link above demonstrates how you can edit this and make Firefox always render all fonts crisp and pixel-ish, without any AA (this is especially good for webdesigners and people like me who hate anti-aliased fonts because of their visual artifacts).

The fix requires that you have root (a.k.a. admin) privileges (many tutorials on how to 'go root' are available online).

BTW, I'm a total newbie at Linux and Ubuntu is my fist Linux distro, which is why I approach such annoying 'bugs' from an end-user point of view (i.e. quick fixes). Despite this, Ubuntu 10.10 has been a mostly great experience for me and I wholeheartedly recommend it (as well as support all GNU/Linux distros and the open-source and free software movements). :)

I hope this helps. Cheers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.