Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Several of my parents' photos in F-Spot have gone missing. I can't seem to figure out the location of the photo file that F-Spot expects to find. I've been looking around for something like "Photo Properties" but so far I haven't seen it.

This is sounding confusing, so hopefully a screenshot will help clear things up:

enter image description here

  • In this photo, F-Spot is missing a picture.
  • We can see that the filename is img_0445.jpg.
  • I've found the actual photo in my backups.
  • I'm having a hard time replacing the missing photo, because I can't figure out in which directory F-Spot is expecting to find the photo.

Is there any way, using F-Spot to find the File Location of a photo? Something like Banshee's "Open Containing Folder"? I thought previously you could right-click a photo and choose "Copy File Location", but I'm not seeing that option in F-Spot 0.8.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You could interrogate the f-spot database itself to search for the filename in question. Once found, the file-location that f-spot was expecting will be available. This method would be particularly useful if you've got lots of pictures to search for.

Install sqlite3:

sudo apt-get install sqlite3

Now dump the f-spot database:

sqlite3 ~/.config/f-spot/photos.db .dump > ~/filelocations.csv

Using LibreOffice Calc - open the file filelocations.csv and search using the filename with the missing picture. The filename should exist in two rows - one or both of which should display your missing file location.

for example

enter image description here

share|improve this answer
    
Good call! I was going to suggest search the database :) –  RolandiXor Aug 7 '11 at 12:26
    
Good call indeed! Even better, using the Sqlite Database Browser, I can view the database directly and make updates to the incorrect locations. After making a backup copy, of course. ;) –  michaelms Aug 7 '11 at 14:50

All the photos are stored in Photos folder in Pictures folder in your home. And each photo is stored according to the date the photo is taken like this "Pictures/Photos/Year/Month/date".

For example if your photo is taken on 2011-10-20. It is stored in Pictures/Photos/2011/10/20 path.

share|improve this answer
    
Over the years, F-Spot's default location has changed from ~/Photos to ~/Pictures/Photos. This has left a lot of clutter in various places in the home folder, and I think it's what led to the missing files in the first place. I need to know -- on a picture-by-picture basis -- where F-Spot is looking for each photo. –  michaelms Aug 5 '11 at 14:44
    
F-spot stores pictures according to the Date the picture has been taken. For instance if you have 2 photos taken on 2011-10-20 and 2011-10-21 they will be stored on ~/Pictures/Photos/2011/10/20 and ~/Pictures/Photos/2011/10/21. So what you have to do is check the date the photo has taken (you can do it by right clicking the picture and go to the image tab -- nautilus) and put it in to the specific folder as I have mentioned. –  Manula Waidyanatha Aug 6 '11 at 6:32
1  
Thanks for your help, but the date isn't the part of the file location that I'm worried about -- it's the first part. Some pictures are stored in ~/Pictures/Photos, some in ~/Pictures and some in ~/Photos (and some in various other locations). I can find the photos, but F-Spot can't, and I'd like to know where it's looking for each individual picture (which varies wildly from one photo to another). –  michaelms Aug 6 '11 at 18:41

I found a (slightly complicated) solution. Right click the photo from the standard view (the one you get when you first Open F-Spot), and choose open with>Image Viewer.

In Image Viewer (in this case EOG), right click the picture and choose properties. It will show you where you photo is.

enter image description here

share|improve this answer
    
While this works well for regular pictures, I'm fairly sure F-Spot doesn't let you attempt to open missing pictures with external applications. –  michaelms Aug 7 '11 at 11:44
    
@MichaelMS have you tried? If you have, then the only other option will probably be to open the database manually... –  RolandiXor Aug 7 '11 at 12:25
    
I had tried it a couple days ago, and I just double-checked. "No Applications Available" for "Open With..." on missing photos. Database it is, then. :) –  michaelms Aug 7 '11 at 14:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.