Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.04 64bits in my new computer, and I got this two messages after login:

error 1

and

error 2

I've tried to login with classic gnome, and safe mode, but got the same messages.

Any easy/fast solution to this? (if not I can use Ubuntu 10.10 for while)

My computer is an HP Pavilion, intel i3, 4GM ram.

share|improve this question
    
Could the issue with the ICEauthority be related to encryption of your file system. Try logon with the same pw with which the file system was encrypted –  tribe99990 Jun 7 at 19:08

8 Answers 8

up vote 7 down vote accepted

It's a simple permissions issue. One of two things will work:

First, try the following:

sudo chown username:username .ICEauthority

sudo chmod 0644 .ICEauthority

Change username to your own username (so in your situation it would be wellington).

If that didn't work, you'll need to (unfortunately) start with a new /home directory - however, BACK UP YOUR DATA before you do that. For more on backup solutions, see

share|improve this answer
    
The sudo chmod 0644 .ICEauthority returned chmod: cannot access '.IECauthority': No such file or directory –  Tom Brito Aug 3 '11 at 21:52
    
After restarting I got the same messages. I couldn't understand why the first command worked, and on the second it says that there's no such file.. I tried removing the dot and putting a space . IECauthority but nothing changed. I know the file is there, as the first command worked.. –  Tom Brito Aug 3 '11 at 21:59
    
@Tom Give sudo chmod 0644 /home/<USERNAME>/.ICEauthority a go –  jrg Aug 3 '11 at 22:06
    
before I type, I got another message, now from Nautilus with permissions problems in the /home/ folder, and I remembered I used the same /home/ I was using with Fedora, so maybe there's something wrong with it.. I will re-install and format the /home/ partition. I think this will solve everything. I back here to tell. –  Tom Brito Aug 3 '11 at 22:55
    
formatting the /home partition solved =) It were problems with the /home created by Fedora. –  Tom Brito Aug 4 '11 at 12:15

I managed to fix the issue by changing ownership and permissons on the folder itself, I used this:

sudo chown username:username /home/username
sudo chmod 700 /home/username

This cleared the problem right away for me.

share|improve this answer
    
the only that worked for me –  geogeek Oct 3 '13 at 8:29

I had today the same problem, when I moved 'Home' users folders to a different partition. I solved it, not changing permissions in '.ICEauthority' file (in fact, I deleted it), but changing the owners of that folders to their users, recursively:

sudo su
chown -R user /home/user

To do that, in login window, ALT+CTRL+F1 changes to a console. After that, ALT+CTRL+F7 returns to GUI mode. No need to reboot.

P.S.: Having 'home' in a separate partition, is a good way to prevent system crashes, and to upgrade versions. See wiki. I used it to install Ubuntu 12.10 in one notebook, and just to separate partitions in another notebook with 12.04LTS.

share|improve this answer

I recently had this problem.

It is a file permission problem but don't assume it is .ICEauthority only. In my case the home folder permissions had changed (how? I do not know)

Took me a while to figure it out because I never expected my home folder permissions to change.

So your home folders permissions should be 0755 or 0700 or whatever (7 must be a 7 though) and .ICEauthority should work with 0600 If you need to use 0644 something is probably wrong.

share|improve this answer

CTRL+ALT+F2 at the login window to switch to a vt command line and login there, Then type: sudo chown username:username ~/.IceAuthority

And then type: chmod 0600 ~/.IceAuthority

Hit ALT+F7 to get back to the graphical login window and try to login there

share|improve this answer

See this link.

Bug 13534 "Could not update ICEauthority file /.ICEauthority" on bootup build 130 and above

After the system boots, the following warning dialog boxes may be displayed:

Could not update ICEauthority file /.ICEauthority

There is a problem with the configuration server (/usr/lib/gconf-sanity-check-2 exited with status 256)

Work-around: Clicking on the "Close" button for each dialog box will permit one to login normally. Once logged in, enter the following command to correct the home directory for the "gdm" user

$ pfexec usermod -d /var/lib/gdm gdm

Edit: Ubuntu uses Lightdm in recent releases instead of GDM.

share|improve this answer

Try adding the user with the home directory addition switch ;) useradd -m blah blah blah Start right, end right.

share|improve this answer

@daedlanth

That was right. I created a user with useradd and then passwd, I got ICEAuthority error. Then, I deleted the account, followed all the right steps, logged in and there I got the desktop without any problems!

Steps for your reference (taken from http://www.blackmoreops.com/2014/03/03/20-things-installing-kali-linux/)

useradd -m user1
passwd user1
usermod -a -G sudo user1
chsh -s /bin/bash user1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.