Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Microsoft Office 2007 installed with PlayOnLinux (Wine), it's working all fine, except that it will not check Spelling & Grammar in Portuguese (Brazil).

The spelling check in English occurs perfectly. In Portuguese it says that all is right, even when it's not. It's like it just accept everything I write as correct.

Any idea how to solve this? Does Wine support the MS Office's spelling check feature at all?

--update:

Just realized that the Spelling Check also is not working on Libre Office for my language (Portuguese, Brazil), maybe the problem is bigger then I thought.

share|improve this question
2  
Why not use libre office? –  user606723 Aug 2 '11 at 19:38
    
@"Tom Brito" - have Clicked on Word Options - Proofing - Dictionary language and chosen the correct language? –  fossfreedom Aug 2 '11 at 20:00
    
@user606723 As this can go really far, I think it would be better to start another thread on this. You may ask here in the site "why one prefers MS Office to Libre Office?", and I can put my answers there. –  Tom Brito Aug 2 '11 at 20:04
    
@fossfreedom Yes. –  Tom Brito Aug 2 '11 at 20:05
1  
I use Microsoft Office at work and I am well aware that it is a superior product. I did not want to talk about that However, libre office works almost as well for 95% of use. I guess the question I had was.. have you tried using libre office and are you sure it won't be good enough for your use? –  user606723 Aug 2 '11 at 20:08
show 7 more comments

1 Answer

up vote 1 down vote accepted
+50

I used Open office for this answer. I believe Libra Office is not that much different in regards to how language functionality works.

  • Open the tools menu in office navigate to options

Tools Options

  • Select Language settings
  • then Languages

Language settings

  • Here you can see select which language you want to set as the defautl language for you documents. Notice the ABC with the blue tick that idicates a language with spell checking capabilities.

select the language

  • If your language comes up with out the ABC blue tick spell check support you will need to install the additional language packs.

enter image description here

$ sudo apt-get install "(myspell|libreoffice).*-pt-br$"

That should install all the language packs for libreoffice that you need. As well as the spell checker which is myspell. If you want to check what will be installed as a -s to apt-get to check. -s will just show you what would have been done with out actually doing any thing.

$ apt-get -s install "(myspell|libreoffice).*-pt-br$"

As for micro-soft office it also needs to have the additional language packs installed.

In ms-office 2007 you need do the following

  • Click the office button (the wheel thing in the top left corner)
  • Click the Word options button on the bottom right of the menu.
  • Select the popular options on the left.
  • then click the language settings button near the bottom of the screen on the left pane.
  • Select your language in the right pane under "Avalible editing languages"
  • click the add button in the middle to add it to the "Enabled editing languages"
  • Then select it as the "Primary editing language" from the drop down bellow.
  • Office 2007 will now use that as your language
  • You may need to install additional languages as part of your office installation process. As it defaults to English.

.

share|improve this answer
2  
Libre Office is working, it's enough for now. For the MS Office I will need to re-install and install the "profiting tools". Thanks! –  Tom Brito Aug 25 '11 at 12:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.