Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, Im pretty versed with Couch on a Mac and I know its the same sort of system on Ubuntu however I have a major issue.
My contacts database corrupted in the sense that it lost everything in UbuntuOne and then deleted it all in Evolution. See the system works lol

Tried to delete the local database using

wget http://people.canonical.com/~roman.yepishev/us/desktopcouch-admin.py python desktopcouch-admin.py --drop

This worked fine however purging the server end using this

wget http://people.canonical.com/~roman.yepishev/us/ubuntuone-couchdb-query python ubuntuone-couchdb-query --http-method=DELETE contacts I get this:

christopher@christopher-Compaq-Mini-110c-1100:/tmp$   python ubuntuone-    couchdb-query     --http-method=DELETE contacts
Traceback (most recent call last):
  File "ubuntuone-couchdb-query", line 269, in <module>
   application.run(args[0], options)
  File "ubuntuone-couchdb-query", line 148, in run
    self.main(url, options)
  File "ubuntuone-couchdb-query", line 153, in main
    show_tokens=options.show_tokens, show_account=options.show_account)
  File "ubuntuone-couchdb-query", line 207, in request
    " %r" % (resp['status'], content))
Exception: There was a problem processing the request:
status:503, response: '<!DOCTYPE HTML PUBLIC "-//IETF//DTD <br>HTML 2.0//EN">\n<html>    <head>\n<title>503 Service Temporarily Unavailable</title>\n</head><body>\n<h1>Service     Temporarily Unavailable</h1>\n<p>The server is temporarily unable to     service your\nrequest due to maintenance downtime or capacity\nproblems. Please try again later.</p>\n<p>Additionally, a 404 Not Found\nerror was encountered while trying to use an ErrorDocument to handle the request.</p>\n<hr>    \n<address>Apache/2.2.14 (Ubuntu) Server at couchdb.one.ubuntu.com Port      443</address>\n</body></html>\n'

I have logged in to Futon and checked the database and I have an empty contacts database with 0kb however in Evolution I have contacts?

Is there a way to rebuild the databases or create a new link to a new database between U1 - CouchDB - Evolution?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

That is the response from couchdb.one.ubuntu.com. Their service is down. It's been down for quite some time now, actually. At least six weeks. And there is not a word about what the problem is or when it's coming back up. :|

share|improve this answer
    
As annoying as that is I thank you for that answer. Maybe I can close Terminal now and give up until 11.10 is released and hope the Mozilla sync will be running! –  Christopher Stansbury Aug 2 '11 at 20:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.