Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upgrade the version of PHP installed on an Ubuntu server 10.10 from 5.3.3 to 5.3.6

I followed the instructions from here and all seemed to go well, but when I run phpinfo() it's still showing the old version.

If I run

php --version

from the command line it says 5.3.6. What do I need to do to get Apache to use this version?

share|improve this question

closed as too localized by fossfreedom Feb 25 '12 at 13:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Restart apache then see if you still get that error. –  Thomas W. Aug 2 '11 at 15:16
    
Just wanted to know. Are there some significant changes from 5.3.3 to 5.3.6? –  Manish Sinha Aug 10 '11 at 19:20
    
Have you also installed php mod for Apache to the correct version? That acts as a bridge –  Manish Sinha Aug 10 '11 at 19:22
    
Please mark an answer as correct or add your own if this has been solved. –  Lewis Goddard Feb 24 '12 at 17:06
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  fossfreedom Feb 25 '12 at 13:15

1 Answer 1

Thanks to reload, we can reload the Apache configuration without restarting (and in the meantime stopping) the service itself, it is as simple as calling:

sudo /etc/init.d/apache2 reload
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.