Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So every once in a while compiz will crash, sometimes randomly, more often when I'm messing with the compiz settings.

I can restart compiz with compiz --replace, and it fixes the window decoration, etc., but that command never finishes in the terminal. If I close the terminal or ctrl-C, it causes compiz to crash all over. So the only thing I can do is just leave that terminal running (not a great solution).

share|improve this question

3 Answers 3

up vote 7 down vote accepted

This is the normal expected behaviour. If you hit CTRL+C compiz will stop. If you want to detach some command from the terminal (so it will not terminate with the terminal, and it will allow you to continue to use it) you can use nohup, like this:

nohup compiz --replace

There is much more info in this question.

share|improve this answer
1  
Personally, I just hit CTRL+ALT+F1, launch compiz in the console and keep it running in the foreground there, that way I can check the output. –  Javier Rivera Aug 2 '11 at 15:16
    
That definitely answered my question, but as an aside, some compiz crashes so bad, the shortcut key to open a terminal is shot too. i know that I can open up a virtual terminal, and use DISPLAY=:0 compiz --replace, but this doest work with my dual monitors, it seems to reset things so everthing is on one monitor. you know the right command to make this work? –  chrismarx Aug 2 '11 at 18:33
    
Sorry but no. I also use dual monitor (well the laptop lid and a external monitor) and compiz --replace keeps my settings (I'm still using both monitors, programs stay where they should) when I do it. The problem likely lies somewhere else. –  Javier Rivera Aug 3 '11 at 6:51

You can also use the Compiz Fusion Icon, which can easily be installed by dropping in a terminal the next:

sudo apt-get install fusion-icon

And after providing your password the fusion icon will be installed and a shortcut can be reached inside of the "System Tools" menu in the majority of the cases, if not, in a terminal drop the next:

fusion-icon

and in the Fusion Icon menu (right click), choose "Reload window manager" in order to force Compiz to reload, after which all your compiz features will get enabled and should not break after closing the Fusion Icon (even from Terminal).

enter image description here

Good Luck!

share|improve this answer
    
i will try this, but unfortunately, I dont think this will be a good solution, because when compiz crashes, it usually takes the system bar with it, so i wouldnt be able to restart from that button –  chrismarx Aug 2 '11 at 18:29
    
Then you are experiencing a kind of major issue with something else, try using cairo-dock's compiz gadget or anything else that allow you gain access to these features, and try updating/upgrading your system/compiz, may I suggest to remove compiz and reinstall it? Your comments on this and your accepted answer leads to think something's wrong with your system... Please inform if you succeed... –  Geppettvs D'Constanzo Aug 2 '11 at 21:13
    
i mainly noticed compiz crashes when i was changing settings, ever since making the main compiz changes, I haven't had to change much and i haven't been seeing crashes- –  chrismarx Aug 11 '11 at 17:41

You can use this as an alternative to nohup: compiz --replace &

share|improve this answer
    
what does the & do? –  chrismarx Aug 3 '11 at 20:16
    
i tried this, didnt seem to change anything –  chrismarx Aug 4 '11 at 19:12
    
compiz --replace & disown After doing this, you can hit ENTER and you should see a fresh prompt. –  earthmeLon Jun 9 '12 at 23:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.