Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to connect to a wireless access point when the SSID contains an underscore in the name from my Ubuntu 11.04 laptop.

Not sure whether it is permissible to have underscores in an wireless SSID, however my Windows laptop connects okay.

It's a public access point, so unfortunately I can't change the SSID. I have replicated the issue on my home wireless access point.

Not sure whether this has anything to do with the issue, but when I run iwlist wlan0 scan there are a number of results with ESSID:"\x00".

I'm going to see whether I can get the MAC address of the router to see which one is a match.

The output from lspci | grep -i Network

02:00.0 Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01)

Any suggestions (aside from renaming the SSID) most welcome!

share|improve this question
    
sounds like a bug - should be reported on launchpad. I dont have the means to test this - but you could try escaping the SSID i.e. "somename\_ssid". Maybe an alternative wireless manager such as wicd might work. –  fossfreedom Aug 2 '11 at 15:36
    
I tried escaping with a \ however it still didn't work. –  VirtualStaticVoid Aug 4 '11 at 7:53
    
Welcome to Ask Ubuntu! In the future please edit your post with new information instead of posting it in the comments section :) –  Marco Ceppi Aug 6 '11 at 22:35
    
I had for long time an EESID with and underscore, and had no problem at all, maybe I'am been lucky with my modem/router. –  enzotib Aug 7 '11 at 7:48

1 Answer 1

SSIDs are limited to upper and lower case letters and numbers and a maximum length of 32 characters. Even though it's not technically legit, you could try doubling the underscores when you enter the name, per Launchpad bug 685588 in case it's the accelerator bug you are hitting.

share|improve this answer
    
surprising that the management pages for the router allow for invalid characters to be entered when editing the SSID –  VirtualStaticVoid Aug 4 '11 at 7:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.