Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from Maverick to Natty and this problem has appeared after the upgrade - it never happened while I was on Maverick.

I'll try to explain this as well as I can.

On Maverick when I plugged/unplugged the external display to my laptop I had to manually enable/disable the external display from the Monitors dialog.

By Monitors dialog I mean this:

enter image description here

But on Natty, when I plug/unplug the monitor this is automatically detected and the display is enabled/disabled, without me needing to go that Monitors dialog and do anything. I think that the OS does some polling of the external display port to see if something is plugged.

My problem is, when I have already plugged an external monitor and am using it, sometimes it becomes disabled by the OS, as if I had went to the Monitors dialog and disabled it manually, only I didn't do anything, I am watching a movie and I'm not near the computer at all. I think that this autodetect feature disables it. It seems that it thinks that I have unplugged the cable, even though I haven't. I think that the VGA cable doesn't make good contact with the pins in the laptop's VGA port so it might be disconnecting for a fraction of the second, but this wouldn't be a problem if there wasn't this autodetect feature.

share|improve this question
add comment

1 Answer 1

Try Caffeine to keep your monitor on, use these command in Terminal.

sudo add-apt-repository ppa:caffeine-developers/ppa

sudo apt-get update

sudo apt-get install caffeine

Caffeine is used to supress any power saving mode from being turned on; e.g. When you're watching a film and the screen goes into idle mode.

I use Caffeine myself and think it's brilliant.

share|improve this answer
    
My problem has nothing to do with screensavers or power-saving. If it were because of that, the primary monitor would be affected as well, and it is not. –  sashoalm Aug 2 '11 at 14:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.