Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After playing around with my drivers, my Nouveau driver no longer seems to support 3D acceleration: Compiz effects are gone, as are 3D gaming capabilities.

Nouveau is still doing something correctly in 2D (e.g. the 1600x900 resolution is still correct, as compared to no NVIDIA driver at all, when it's 1280x768 instead).

How do I fix this without reinstall Ubuntu for the billionth time?


xorg.conf's that I've tried:

  • (empty)

  • This (which was the original):

    Section "Device"
           Identifier      "Default Device"
           Driver  "nouveau"
    EndSection
    

Other things I've tried:

  • modprobe nouveau

  • sudo apt-get purge xserver-xorg-video-nouveau --remove

  • sudo apt-get install xserver-xorg-video-nouveau --reinstall

  • Uninstalling/reinstalling through Additional Drivers

share|improve this question
    
1. Remove the xorg.conf file. 2. Please add the output of ls -al /etc/alternatives/gl_conf. 3. Do you have a file called nvidia-installer-disable-nouveau.conf (or similar) in /etc/modprobe.d? 4. Are nvidia or nouveau in the output of`lsmod` after a boot? –  htorque Aug 2 '11 at 7:56
    
5. Did you recently update the system (like Xorg related packages)?6. Are you using any Xorg PPAs by any chance? –  htorque Aug 2 '11 at 8:14
    
@htorque: 1. Done. 2. lrwxrwxrwx 1 root root 24 2011-08-01 23:52 /etc/alternatives/gl_conf -> /usr/lib/mesa/ld.so.conf. 3. No, I've removed that when uninstalling the proprietary driver. (nouveau does start, it's just that I don't get 3D acceleration anymore, just 2D graphics). 4. Yes, there are 5 entries that match nouveau. 5. No. 6. No. This thing was fine like 20 minutes before I fiddled around with the drivers, I didn't add/remove anything else during that time :) –  Mehrdad Aug 2 '11 at 11:36
add comment

1 Answer

up vote 3 down vote accepted

Fixed...

(But I'm not sure why!)

I followed these instructions to reinstall the drivers, and rebooted.

Nothing changed.

Then I went into Additional Drivers and enabled Nouveau (which I'd already enabled and disabled numerous times, and which should have been enabled here)... and then I got 3D after I rebooted.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.