Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install a game that has a two-CD installation, and I get this error message:

The file '/media/FREESPACE_1/Setup.exe' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

Since it's on a CD, it is a read-only file and therefore I cannot change the permissions. Any ideas how to solve this?

share|improve this question
    
possible duplicate of Windows installer on CD (executable bit) –  enzotib Aug 2 '11 at 6:36
add comment

2 Answers

up vote 2 down vote accepted

You can try starting wine from terminal, giving it the name of your executable as an argument:

cd /media/FREESPACE_1
wine ./Setup.exe

Another option would be to somehow remount the cdrom passing different "mode" parameter to isofs driver - by default mode is 0400, which is "owner read-only", i.e. "r------". You need to change it at least to 0500, i.e. "r-x------". So something along the these lines technically should help - however, I couldn't make it work in my brief testing:

sudo mount /media/FREESPACE_1 -o remount,exec,ro,mode=500
share|improve this answer
    
To start a terminal in Ubuntu, go to Applications - Accessories - Terminal. If you're using the latest Ubuntu (with Unity), pressing Alt-F2 and typing "term" should show the icon –  Sergey Aug 2 '11 at 5:47
    
Pheew, lots of big programmer words in that second option, Sergey! :) You lost me at "isofs". I'm gonna try the first one. –  Ralf Tiede Aug 2 '11 at 23:05
    
I'm sure I'm doing something wrong, but when I type that first line into the terminal, this is what I get: bash: cd: /media/freespace_1: No such file or directory –  Ralf Tiede Aug 2 '11 at 23:08
    
Ralf, I took the path from your question: "...file '/media/FREESPACE_1/Setup.exe' is not marked as...". Note that file and directory names in Unix are case-sensitive, so you should enter them exactly as they are, without changing case. So, if you enter "cd /media/FREESPACE_1" literally I'm pretty sure it should work –  Sergey Aug 3 '11 at 0:24
    
Not quite related, but may be helpful: auto-completion in terminal allows to avoid typing errors... start typing "cd /me", then press tab, then enter the first letter (F in your case), tab again - done. When it cannot auto-complete because your input in ambiguous, hitting tab twice lists the options. –  Sergey Aug 3 '11 at 0:29
show 1 more comment

This is going to be a easy fix.

  • open terminal

gksudo nautilus ( <<< be careful you will be using nautilus as root)

put in your password

go to your cdrom and right click on setup.exe

goto permissions make the changes you need (check mark allow to run as executable ) close the property window and double click Setup.exe

Should work if wine and the game plays nice together.

Seeing that it didn't work you can also copy the cd to your hard drive and should be able to change permissions of the files on your drive.

share|improve this answer
    
Thanks. Pardon my ignorance, but I'm new to Ubuntu. I'm running the Classic view, and I have no idea how to open the terminal. –  Ralf Tiede Aug 2 '11 at 5:32
    
Actually, I just found it. :) –  Ralf Tiede Aug 2 '11 at 5:33
    
Nope, still doesn't allow me to change the permission. :( –  Ralf Tiede Aug 2 '11 at 5:37
    
You cannot change permissions on a read-only media. Moreover, it is probably a ISO9660 filesystem that do not support executable bit (if it has not Rock Ridge extensions). –  enzotib Aug 2 '11 at 6:36
1  
But even if you are root, you can't do modification on a filesystem which is read-only ... And altering permission means writing to the filesystem, which requires read/write fs, of course. –  LGB Aug 2 '11 at 12:56
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.