Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Under 10.04 it was possible to use the gconf-editor system/storage setting to specify the default permissions for vfat and ntfs file systems when a USB drive was mounted. That seems to be missing in 11.04 in gconf-editor and dconf-editor. The automount gives no permissions to other users and groups to access the files and programs such as MediaTomb can not access files on a USB drive unless I format it in ext3.

How can I change the permissions at or after mounting - any change does not seem to be sticky on a ntfs or fat32 USB drive.

share|improve this question
    
This question is of help askubuntu.com/questions/39552/… ? –  enzotib Aug 1 '11 at 20:39

2 Answers 2

NTFS and FAT do not store permissions, so they are faked, making it look like you ( the person logged into the console ) own and can access the files, but not other users. If you add an entry to /etc/fstab, you can specify the umask option and set whatever permissions you want.

share|improve this answer

you should edit the /etc/fstab file and create a specific line for the device you want, more info can be found here: http://www.tuxfiles.org/linuxhelp/fstab.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.