Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Twice now an upgrade of the proprietary ATI Catalyst driver has been a major pain, even with the help of excellent guides.

These commands all run successfully (as in $? -eq 0):

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* \
xorg-driver-fglrx
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper \
debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 \
dh-modaliases # Already installed
sudo apt-get install ia32-libs # Ditto
sudo sh ./ati-driver-installer-11-7-x86.x86_64.run --buildpkg Ubuntu/natty
sudo dpkg -i fglrx*.deb

After a restart it crashed during the graphical boot phase. Restarted in safe mode, and restored the old configuration:

sudo mv /etc/X11/xorg.conf{.fglrx-N,}

Now it boots, and goes straight into the correct video mode, but the version number shown in CCC still says 11.5!

Tried uninstalling the drivers, and noticed some warnings:

dpkg: warning: while removing fglrx, directory '/usr/lib32/fglrx' not empty so not removed.
dpkg: warning: while removing fglrx, directory '/usr/lib/fglrx/etc/ati' not empty so not removed.
dpkg: warning: while removing fglrx, directory '/usr/lib/fglrx/etc' not empty so not removed.
dpkg: warning: while removing fglrx, directory '/usr/lib/fglrx' not empty so not removed.

Tried to install without generating the packages:

sudo sh .../ati-driver-installer-11-7-x86.x86_64.run

It says the packages are still installed! Verified with the following command:

$ apt-cache pkgnames --installed | grep fglrx
fglrx
fglrx-dev
fglrx-amdcccle

What can I do at this point? I even tried to remove the /usr/lib32/fglrx and /usr/lib/fglrx directories, but that didn't help.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

I know when I have reinstalled fglrx I have usually done what you have done but slightly differently as I have usually had to go back to the open source versions for a while.

I found this guide to be really helpful

Ati Ubuntu Wiki

However this worked for me last time and got rid of pretty much all of the ati/fglrx stuff left on my pc

sudo /usr/share/ati/fglrx-uninstall.sh  # (if it exists)


sudo apt-get remove --purge fglrx*

As a further measure I also check what else is left

dpkg -l '*fglrx*'

and

locate fglrx

I also make sure I have a correct set of open source drviers installed

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon 
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

I then rebuild the the proprietary fglrx/Catalyst driver to be installable through the Restricted Hardware Driver Manager (a.k.a. jockey)

 sudo apt-get install fglrx-modaliases

After these have all been completed I reboot and now the open source drviers are working AND xserver-xorg has bene rebuilt I reinstall fglrx

sudo apt-get install fglrx

That seemed to do the trick last time.

Let us know how you get on

share|improve this answer
    
After running this and installing Catalyst 11.7 it still says 11.5 in CCC :/ –  l0b0 Aug 1 '11 at 16:27
    
Rinse, repeat, and it worked! Thanks! A little violent rm -rf of the locate results was necessary... –  l0b0 Aug 1 '11 at 16:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.