Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I have a laptop 15' and was going to use 23' external monitor.

I attached it and they both were working fine. But what I wanted is just to use only one monitor and leave laptop's display to be turned off.

I couldn't find a way to do it and after playing with settings I turned first monitor off hoping that system decides to use the second one as main monitor.

However they both are now showing black.

I am having to detach my second monitor and restart my machine (from another terminal's console)

What I want..is just turn laptops monitor off and use 23' one when it's attached.

I would also be quite happy if you would tell me where does Ubuntu store settings about monitors.

I also would to at least to be able to use two monitors at the same time (i.e revoke my last change)

share|improve this question
1  
okay! I've found it in ~/.config/monitors.xml Just deleted that file and I reverted my changes. –  bakytn Aug 1 '11 at 11:45
    
Now I'm trying to make my second monitor to be default (main) monitor and leave laptop's monitor turned off. –  bakytn Aug 1 '11 at 11:46
    
So I drag and dropped the second monitor behind the laptop's monitor in Monitors tool and things seem worked. But I encountered another issues like the Dash is showing only on Laptop's display (when you press the Win key) also I'm seeing a black rectangle on the bottom and can't resize the window to have it bigger than 1600px (the width of frist monitor) –  bakytn Aug 1 '11 at 12:03
    
Set the external monitor as primary in minitors.xml but things are not showing good. –  bakytn Aug 1 '11 at 12:17
add comment

2 Answers

up vote 1 down vote accepted

If you are on 11.04 type monitor on unity launcher

Then you will see your monitors like this

enter image description here

If you want to turned of the laptop screen and use the external one jsut select the laptop monitor and then click on Off radio button. then click on apply

like this: enter image description here

Now you have only the external monitor.

Update - Replying to the comment below.

You should remove ~/.config/monitors.xml and try again.

share|improve this answer
    
yes, I did exactly this. both monitors went off. –  bakytn Aug 1 '11 at 12:01
    
I also drag and dropped the second monitor behind the laptop and things seem worked. But I encountered another issues like the Dash is showing only on Laptop's display (when you press the Win key) also I'm seeing a black rectangle on the bottom and can't resize the window to have it bigger than 1600px (the width of frist monitor) –  bakytn Aug 1 '11 at 12:03
    
If you turned off the laptop monitor, the launcher doesn't show up on the external monitor? –  Achu Aug 1 '11 at 12:20
    
If I turn the laptop monitor off...all monitors are black and impossible to work. –  bakytn Aug 1 '11 at 12:32
add comment

I had the same problem and google led me here. I was able to solve the problem by deleting ~/.config/monitors.xml and then used the display settings to turn laptop monitor off. And it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.