Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung SCX-3201 MFP multifunction printer and after plugging it into the computer it recognises the printer part, but the scanner is not detected.

Since that I've fresh installed and did not try it again. The built-in scan application nor SANE detects it.

I did try Samsung's proprietary software.Neither did it detect it

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
+50

Not Supported

Having checked the stable version of the SANE libraries that is included in Ubuntu from the sane-project website, the scanner in question is not yet supported.

To double check this you'll need your USB identifier that you can obtain using lsusb.

The SCX range of scanners use the sane-xerox_mfp back-end.

Checking the unstable version (the version you will need to compile from GIT source) again your scanner is not supported.

Possible solution

Possibly you can add your model if it is similar to one of the listed models in the above links. This involves adding the USB ID to /etc/sane.d/xerox_mfp.conf together with similar information to the SANE rules in /lib/udev/rules.d/40-libsane.rules

Obviously change the values to match your scanner.

To give you an example add the following text to /etc/sane.d/xerox_mfp.conf:

#Samsung CLX-3185FW
usb 0x04e8 0x343d

and /lib/udev/rules.d/40-libsane.rules by adding

# Samsung CLX-3185FW
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="343d", ENV{libsane_matched}="yes"

Make sure you install the following package:

sudo apt-get install acl

source

If the above does not work, try also adding your user account to groups lp and scanner by:

sudo usermod -a -G lp [username]
sudo usermod -a -G scanner [username]
share|improve this answer
    
It works.. kinda only gets part of the picture –  Minato Namikaze Sep 21 '11 at 12:13
    
hmmm - what software are you using to scan with? Does it have any options to manually specify the area to scan? –  fossfreedom Sep 21 '11 at 12:23
    
This worked for me, too, but not immediately. I found the codes to add to files /etc/sane.d/xerox_mfp.conf and /lib/udev/rules.d/40-libsane.rules by commanding sudo sane-find-scanner. Following advice I read elsewhere, I also added myself to groups lp and scanner (by commanding sudo usermod -a -G lp teemu and sudo usermod -a -G scanner teemu), then rebooted. After this, simple-scan started working. –  Teemu Leisti Jun 3 '12 at 13:05
    
@TeemuLeisti - many thanks - I've added your advice to the answer. –  fossfreedom Jun 3 '12 at 14:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.