Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Been trying to install git-core package for almost more than half a day now. Everytime i do, I get this error:

dpkg: error: parsing file '/var/lib/dpkg/available' near line 0:
newline in field name `../../../../../share/pyshared/UpdateManager/Core/'

I've also tried running sudo apt-get update and sudo apt-get install --fix-missing. Even tried rebooting and cleaning the apt-get cache, still doesnt work.

share|improve this question
Finally, a solution! – RolandiXor Feb 7 '12 at 2:37
up vote 53 down vote accepted

The problem is that your /var/lib/dpkg/available file is damaged.

This is not necessarily related to the git or git-core packages. Try to install any other package and they will fail too.

To fix this you have to delete/clear the file using the command:

sudo dpkg --clear-avail

then rebuild the file using the command:

sudo apt-get update

Now you should be able to install git and git-core.

share|improve this answer

From the below error,it was clearly shown that your /var/lib/dpkg/available file was corrupted.

dpkg: error: parsing file '/var/lib/dpkg/available' near line 0:
newline in field name `../../../../../share/pyshared/UpdateManager/Core/'

Solution for the above problem is to replace the current /var/lib/dpkg/available file with another /var/lib/dpkg/available-old backup file.

sudo rm /var/lib/dpkg/available
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available

Now try,

sudo apt-get update
sudo apt-get install -f
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.