Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My display brightness adjustment is off by a factor of 10, i.e. it's brightest at 10% instead of at 100%, and the difference between 0% and 1% is a little too high.

Any way to fix either of these problems? (VAIO CW laptop)

share|improve this question
You should report this as a bug, not sure about the package though. – Lekensteyn Jul 30 '11 at 8:24
@Lekensteyn: For some reason, I just don't yet feel very comfortable creating an account on Launchpad (and related) sites. I was supposed to report something else as well, but I don't think I'm going to, unfortunately. :\ – Mehrdad Jul 30 '11 at 8:28
A LP account can be used for multiple services related to Ubuntu: Launchpad (bugs, code, answers) and Ubuntu Wiki. If you sign up, you'll have to provide an e-mailaddress to which a confirmation mail is sent. See also – Lekensteyn Jul 30 '11 at 8:32
As for the original question, does it happen with your keyboard shortcut or an applet? If you run cat /sys/class/backlight/acpi_video0/max_brightness | sudo tee /sys/class/backlight/acpi_video0/brightness, is your brightness set to 100%? – Lekensteyn Jul 30 '11 at 8:33
@Lekensteyn: acpi_video0 doesn't even exist. (I have an NVIDIA card.) – Mehrdad Jul 30 '11 at 18:01

From the information you've given us, it appears that you need to change your GRUB settings.

To do that, open up a terminal and run the following commands:

gksu gedit /etc/default/grub - what that command will do is open Gedit in "Sudo Mode" and have the GRUB configuration file open.

Then, change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Then, run sudo update-grub and reboot. Brightness problem should be solved.

share|improve this answer
I had high hopes for this, but it didn't seem to work. :( – Mehrdad Aug 9 '11 at 3:58

I have the same laptop and have the same problem. What i have found is that if you go in to gnome configuration editor (gconf-editor) there you navigate to apps, gnome-power-manager, backlight. If i change the key brightness_ac from values 0-12 it affects my screen brightness. However values over 12 up to 100 doesn't make any difference to the brightness compared to 12. When i use the fn+ f5, f6 keys it seams to adjust the brightness in values from 0-100 with increments of 5. I hope this make sense for someone with more knowledge in ubuntu then me

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.