Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded three versions of Firefox: 3.6, 3.5 and 3.0 from Mozilla ftp server. Then I created three profiles, e.g:

firefox -no-remote -CreateProfile firefox-3.5

Then I tried to run it:

./firefox -no-remote -P firefox-3.5

but it failed with the error:

./firefox-bin: symbol lookup error: ./libxul.so: undefined symbol: _Z19js_obj_defineGetterP9JSContextjPi

or

(firefox-bin:4034): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed

Actually it worked in 10.10. I dropped in on Mozilla’s Firefox IRC channel and one dude told me he had never seen this bug before so I suppose that it is Natty issue.

share|improve this question
    
Try to encapsulate the profile name with quotes. Also see my reply below. –  lovinglinux Jul 29 '11 at 19:33

1 Answer 1

up vote 2 down vote accepted

Get FoxTester extension. It allows to install/launch/uninstall multiple versions of Firefox using multiple profiles, directly from your default Firefox.

Keep in mind that FoxTester is designed for testing multiple Firefox builds and not for managing profiles intended for long term usage. If you uninstall a Firefox build installed by FoxTester, it will remove all traces of it, including the profile.

FoxTester install all FF versions and creates the corresponding profiles in the foxtester folder, inside the Firefox profile where FoxTester is installed.

If you want more control over your profiles, then use the standalone profile manager instead. But don't use it to manage FoxTester profiles.

share|improve this answer
    
Either there is no reaction, or in case of Firefox 3.0.9 a tiny blank window of very few pixels is opened. Just like what I had by running profiles via terminal. My system is quite clean, I installed it about 2 months ago. Maybe it matters that I use Kubuntu (though I don’t think so) and I have Firefox from Mozilla ppa? –  rrh Jul 30 '11 at 7:48
    
It doesn't matter, I have Kubuntu also. Are you downloading the binaries with the same architecture of your system? –  lovinglinux Jul 30 '11 at 16:18
    
OK, maybe it matters that I use British English localisation across system but tried to use Firefox with Polish one. Now I could run different versions of Firefox except from version 2.0.20. First, the file pattern is not detected by FoxTester. Second, it won’t even run when it is compressed to bzip. I know that there is a problem with running Firefox 2 in newer Ubuntus but FoxTester should handle it. –  rrh Jul 30 '11 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.