Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sometimes my audio does not work, it all started happening after i updated to ubuntu 10.10 can someone help me?

share|improve this question

closed as not a real question by Marco Ceppi Oct 10 '10 at 16:10

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Please add more details: What happens when you try to play something? What sound card do you have? –  Nathan Osman Oct 10 '10 at 7:31
    
it just doesnt play anything, it all was normal before the update, i think its all because of grub because it only plays sounds when i reboot after windows, from an ubuntu restart it doesnt. –  Eduardo Oct 10 '10 at 7:51
1  
@Eduardo Please edit your question with details instead of leaving a comment. –  moberley Oct 10 '10 at 8:20
    
This is too vague of a question to be objectively answered in it's current form. Please provide more details from logs or more specific information. For extended support on items you may wish to try the Ubuntu Forums or IRC. You may also want to search LaunchPad to see if this has already been reported as a bug. For more information on questions which work best on this site see our FAQ –  Marco Ceppi Oct 10 '10 at 16:10

1 Answer 1

It might be PulseAudio related, since that was the case with me after I upgraded to 10.10.

Here is what I did, to fix it:

PURGE Both PA and Alsa:

sudo apt-get remove --purge pulseaudio
sudo apt-get remove --purge alsa-base

INSTALL both PA and Alsa again:

sudo apt-get install pulseaudio
sudo apt-get install alsa-base

Reboot (or try to Logout and log back in... since i'm not sure at which runlevel Alsa is configured).

CHECK Detected soundcards:

Goto System->>Preferences->Sound (in the Hardware tab), there should be at least one soundcard. Most modes do not work (for me), but the mode Analog Stereo Duplex did. You probably have to see it yourself.

share|improve this answer