Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a GTX470 with an HDMI output, this card is able to handle the video and audio. I have no issues with the video but I get no sound. Is there a guide to enable sound on this card through hdmi that could be written out or I could be guided to. Thanks!

share|improve this question
    
This may seem odd, but could you post a picture of the card itself or provide a link to it? It needs to be specific to the brand that you bought. I only ask because some of the HDMI cards have a 2-pin connector I believe. This connector is needed to make the audio work. Most cards pull sound through the pci slot, but at work I've seen a few that required the cable to get the audio working. If you can eliminate that as a possiblity, then we can move forward troubleshooting the hardware. –  Ctuchik Jul 29 '11 at 14:35
1  
    
I don't see the 2-pin connector so it's likely that the sound is pulled through pci. So you should try this command to see how many sound devices you have installed: "cat /proc/asound/cards" –  Ctuchik Jul 29 '11 at 15:34
add comment

2 Answers

The only way for the moment to have HDMI Audio support in an Nvidia card is by first installing the proprietary drivers and then selecting the HDMI Audio as output.

  1. Install Proprietary Drivers and Reboot PC

    enter image description here

    enter image description here

  2. Go to Sound Settings

    enter image description here

  3. Make sure that in the Hardware Tab you can see the Nvidia card and then make sure that in the Output Tab you can select the Nvidia card. Select the Nvidia Card as the output and you should hear the sound.

    enter image description here

    enter image description here

This should be enough to have sound in any of the Nvidia Cards that support HDMI Sound.

I have tested this with:

  • Nvidia GeForce GT 440
  • Nvidia GeForce GT 220
  • Nvidia GeForce GT 9500
  • Nvidia GeForce GTX 460
  • Nvidia GeForece GTX 560 TI

I also recommend using the Nvidia PPA in this question: Newest Nvidia Card - what driver should I install? which I can say has improved my Nvidia card a bit.

share|improve this answer
add comment

Open the sound settings by clicking the volume applet and selecting "Sound Settings". From there, make sure that under the "Hardware" tab, the HDMI card is selected, as well as under the "Output" tab. That should do the trick

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.