Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Gnome Shell.

Alt+Tab shows all opened application windows from all virtual desktops. It becomes impossible to use when many windows are opened. Is it possible to show only these apps which are on active desktop?

share|improve this question
1  
Try this: askubuntu.com/questions/464946/… :) – ascenator May 14 '14 at 15:31
    
Maybe you should accept an answer ? – Rémi B. Feb 3 at 10:05

One potential option you may wish to consider is the Gnome-Shell Alternate Tab extension

It is the traditional Window-based Alt-Tab switcher that Ubuntu users have grown up with.

  • Windows are not grouped by application, nor by workspace
  • Thumbnails show window previews
  • Windows are sorted by time of focus

It doesnt meet your question "active desktop" criteria - however it does make switching more obvious and easier when you have multiple windows opened.

It is packaged in a PPA

To Install

sudo add-apt-repository ppa:ricotz/testing 
sudo apt-get update
sudo gnome-shell-extensions-alternate-tab

As with all PPAs - these are testing for testing purposes. Either have a full backup you can restore with or use ppa-purge to remove the PPA

sudo ppa-purge ppa:ricotz/testing
share|improve this answer

There is a Gnome Shell extension that does this: Alt Tab Workspace.

You could also directly enable this behavior in the default switcher by running:

gsettings set org.gnome.shell.app-switcher current-workspace-only true

which is what the extension does under the hood.

share|improve this answer
    
This answer reserves higher consideration. As it solves OPs problem with out an extension. I just checked it and found working in Ubuntu Gnome 14.04 . – Ajeeb.K.P Mar 14 at 13:42
    
But it also removes grouping of similar apps. That is if two terminals are open they are shown differently. I think it is not a problem. – Ajeeb.K.P Mar 14 at 13:44

Two ways to solve the problem.

  1. Install a plugin which modifies the behaviour of Alt+Tab to conventional methode. Then it shows all the opened windows go http://fpmurphy.com/gnome-shell-extensions You will find the plugin.

  2. The current Alt+Tab feature is good. You try to understand it in a different way. let me explain. your Alt+Tab will show opened applications. if you have more than one window opened for a same applicaiton then use Alt+~ to switch between windows. It will automatically select the desktop. to change application use Alt+Tab and to change window of same applicaiton Alt+~ that is great way.

share|improve this answer
    
1) I can't see any plugin providing the required functionality on the web you have linked. 2) It's not great, I have been trying to get used to it for several months now, and finally concluded that I don't like it at all. I want to tab just through the windows local to the current virtual desktop. – salva Sep 26 '11 at 10:19
1  
@salva - have you tried the alternate tab extension (live.gnome.org/GnomeShell/Extensions/alternate-tab) - its much better than standard alt-tab i.e. sudo apt-get install gnome-shell-extensions-alternate-tab from this PPA (ubuntuupdates.org/ppa/gnome_shell?dist=natty) – fossfreedom Sep 28 '11 at 10:35
    
@fossfreedom: thanks! write a new answer so I can award you the bounty! – salva Sep 28 '11 at 11:04
    
@salva - have written an answer... – fossfreedom Sep 28 '11 at 11:34
    
re 2: I don't get it. In my opinion if I opened 2 different Terminal windows in 2 separate workspaces it was for a reason. It's because I group my activities by workspaces. For example, in first workspace I compile something using Eclipse + Terminal, in second I opened it to do a quick 'find | sed'. In my opinion Alt-Tab must switch those 2 instances of Terminal as separate application – antimirov Dec 4 '11 at 0:11

You don't need any extension to enable this behaviour. dconf-editor provide this feature as an option:

sudo apt-get install dconf-editor

Then

dconf-editor

This launch an graphical interface of system configuration database.

Navigate into it to org > gnome > shell > app-switcher and then, check the current-workspace-only checkbox option.

Close dconf window and try Alt+Tab. It should work as expected now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.