I tried to install libboost and it failed. Now I'm getting the error that there are unmet dependencies and I cannot do anything involving upgrading or installing packages.
sudo apt-get -f install as recommended in the messages but I get the errors
root@IM-EPI140:~# apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following extra packages will be installed: libboost1.42-dev Suggested packages: libboost1.42-doc libboost-date-time1.42-dev libboost-filesystem1.42-dev libboost-graph1.42-dev libboost-iostreams1.42-dev libboost-math1.42-dev libboost-program-options1.42-dev libboost-python1.42-dev libboost-regex1.42-dev libboost-serialization1.42-dev libboost-signals1.42-dev libboost-system1.42-dev libboost-thread1.42-dev libboost-wave1.42-dev docbook-xsl fop The following NEW packages will be installed: libboost1.42-dev 0 upgraded, 1 newly installed, 0 to remove and 28 not upgraded. 2 not fully installed or removed. Need to get 0 B/6,624 kB of archives. After this operation, 68.9 MB of additional disk space will be used. Do you want to continue [Y/n]? Y dpkg: regarding .../libboost1.42-dev_1.42.0-4ubuntu2_amd64.deb containing libboost1.42-dev: libboost1.42-dev conflicts with libboost-dev (<< 1.35.0) libboost-dev:i386 (version 1.34.1-15ubuntu3) is present and unpacked but not configured. dpkg: error processing /var/cache/apt/archives/libboost1.42-dev_1.42.0-4ubuntu2_amd64.deb (--unpack): conflicting packages - not installing libboost1.42-dev Errors were encountered while processing: /var/cache/apt/archives/libboost1.42-dev_1.42.0-4ubuntu2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
How do I fix this?