Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm just doing a base install of Ubuntu Server. The install goes fine until it reaches the Partitions Formatting section. It just goes to 33% and stays there. I have read on some sites that its still formatting even though it stays on 33% and that it will eventually format. But I left it alone for 12 hours and its still the same. The hard drive is 250GB. I don't think that it should take that long should it? I have tried CD, DVD and Unetbootin including versions 10.04, 10.10, 11.04, but they all do the same thing.

I can install the Ubuntu desktop version quickly with no problems though.

share|improve this question
    
As a workaround, if you partition and format manually, using GParted for example, then the installer works? –  arrange Jul 28 '11 at 18:16
add comment

1 Answer

up vote 0 down vote accepted

It should not take this long at all. Do not rule out that there is something wrong with the drive. It is even possible, though lately rare, for older hard drive firmware to cause general performance issues. Check with the manufacturer. However, my first instinct would be to suspect something is up with the drive.

Also, and you did not indicate, but I have some experience with this. Mostly on real hardware RAID there is a config pushed to the drive. The drive knows it's a member of a raid array. The only way I currently know to reset it is to put the drive back onto a raid controller and let it clear the config. And no doubt, there are probably many more ways to accomplish this.

Going back to my instinct, I would grab an Ubuntu 11.04 or 10.10 live disk. One that you know is good. Boot the box live, go to a terminal, and run a tool called:

palimpset

This will show you the SMART data currently on the drive. If there are high amounts of sector errors, it will be fairly quick to let you know. It's pretty neat because you can get the total time the drive has ran, its current temperature, etc. I hope this helps.

share|improve this answer
    
Thanks Aric, it seemed that it was the drive. I tried it with another one, and it worked just fine! –  amye Jul 30 '11 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.