Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm still at the "figure out what the problem even is" stage of troubleshooting.

The symptom: Amarok is skipping every few minutes in an up-to-date installation of Ubuntu 10.10.

What I've checked so far:

  • Movie Player (Totem) does not skip when playing the same files.
  • The skips do not correlate with increased CPU, memory, disk, or network usage.
  • amarok --debug does not output anything when a skip occurs.

Where should one look to troubleshoot skipping audio?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Since Totem works, it is almost certainly due to the different codec engines in use. Totem and GNOME in general use gstreamer. Amarok and KDE in general use phonon, which in turn uses the xine codec engine by default in Ubuntu, though it can also use gstreamer.

See Amarok's wiki page about phonon.

It sounds like things may work for you if you install phonon-backend-gstreamer and switch to it by default (configure via Settings --> Configure Amarok --> Playback --> Sound System Configuration --> Backend). I'm not sure that won't regress audio playback in new ways though.

share|improve this answer
    
Well, that stopped the skipping. Thanks! Now I go read up on phonon... –  ændrük Oct 15 '10 at 13:41

I'm assuming you already tried fiddling with your cables, and different speakers (headphones)

  1. Try a different player. If that fixes it, try reinstalling Amarok. If that doesn't work, try running CPU monitor or top to see if your machine is doing something every few minutes.

  2. If it's a problem with several players, you could try running off the live CD.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.