Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.04 on my 2010 13' macbook pro using Parallels Desktop 6. I can run Ubuntu Classic perfectly, no lags and everything just works out of the box. When I try to run standard Ubuntu though (with Unity, the new Launcher & Dash etc.), All I see is a solid green rectangle on the bottom-right 1/4th of the screen, and in-place of the top panel I just see a transparent bar. Does anyone have an idea on how to fix this?

share|improve this question
    
I too have had this problem, I can only suggest that you report the bug. On the help menu there is an option to report a problem, although you need to give two sets of id numbers. –  Geoff Hogg Aug 21 '11 at 19:13

2 Answers 2

Unchecking "Enable 3D acceleration" in Video Hardware settings will give you a working Ubuntu again, but without OpenGL :-/

The reason is Unity, the new Desktop Environment for Ubuntu. To continue using 3D acceleration, switch the desktop back to classic Ubuntu:

1: Click on the power button in the upper right corner and choose "System Settings". 2: Search for "Login Screen" and double click 3: Choose Unlock and enter your password 4: Select Ubuntu Classic as default session. 5: Re-enable 3d acceleration in Parallels and reboot

share|improve this answer

I'm not sure but just as virtualbox needs virtualbox addons to support unity, parallels might need some addons to support unity. Also, you might want to check how to enable 3D graphics capabilities as Unity needs that as well.

Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.