Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've successfully burned CDs from .iso images with wodim, but using this:

growisofs -dvd-compat -Z /dev/sg1=ImageToBurn.iso

fails with:

Executing 'builtin_dd if=ImageToBurn.iso of=/dev/sg1 obs=32k seek=0'
:-( write failed: Illegal seek

Brasero seems to work just fine in GUI; am I missing a library? is the command wrong?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I found the same thing happened to me when I tried your command.

Nevertheless, I believe you will find that the following command will work:

growisofs -dvd-compat -Z /dev/dvdrw=ImageToBurn.iso

In Ubuntu, /dev/dvdrw should be equivalent to /dev/sr0, which is a block device. /dev/sg1 is a character mode device for the generic SCSI interface, and that must not be the way growisofs interacts with the dvd device (a seek is normally an operation on a block device).

share|improve this answer

Didn't exactly work on my system, but gave me a clue. I used the below to find a valid name for the command -/dev/sr0 worked here.

sudo lshw -C disk

I used wodim --devices and cdrecord --scanbus before finding John's post and those apparently didn't give me a valid block device name.

I typically have trouble using the GUI applications to burn an iso. It's always something. The command line route has been very dependable for me. I like to burn slow to be sure I get a good burn and the command line does that without complaint.

One issue I've had there is with RW media that's not being detected and needs to be blanked before it can be used, and the command line has been dependable there too. Of course you don't want to blank media that's not re-writable....

Here's what I do to get a good burn from the command line. This is done from the directory where the iso is stored to keep it simple.

if RW media is not being detected...

growisofs -Z /dev/sr0=/dev/zero

and the burn -slow burn in this case, run without speed for full speed...

growisofs -dvd-compat -Z /dev/sr0=ubuntu-13.04-desktop-i386.iso -speed=2 

Thanks all.

Be real, be sober.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.