Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to run the game Cogs from the command line, the game spits out the following error and dies immediately:

Couldn't set 800x600 OpenGL video mode: Couldn't find matching GLX visual

What does this mean, and how can I fix this?

Edit: I have an intel graphics card.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

i have the same problem (different resolution in my case: 1366x768)

the solution was to edit the following file: ~/.local/share/Cogs/cogs.ini (you can see the windows origins of this game from the file and path)

play with the settings there - i would set resolution to 0, and all visual effects to minimum to get it running - then you can always open the settings window and change them to something better

the minimalistic file looks like this:

VolumeMusic 0.044484
VolumeEffects 0.750000
EnableShadows false
EnableFilters false
Fullscreen false
IntervalImmediate true
Resolution 0
WindowPosX 0
WindowPosY 0
Antialiasing 0
Language english
share|improve this answer

This seems to have been reported as being fixed in nvidia v280 if you are using a nvidia card. If so, you can try installing those drivers instead of your current ones.

share|improve this answer
    
I have an intel card, but +1 because this information is useful to those who do have nvidia cards. –  Dan Aug 4 '11 at 22:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.