Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last Friday's Wine update to 1.3.25 broke sound, how do I go back to the previous version of Wine?

share|improve this question
up vote 2 down vote accepted

There are instructions here, on WineHQ. You need to uninstall and reinstall an earlier version. According to the FAQ, this won't uninstall your apps.

It's more likely to be a problem with your configuration or a sound driver, though. You should open up the Wine configuration to be sure.

If the problem is not fixed when you use an older version of Wine, try 1) changing your sound driver to each individual sound driver and no other, then 2) removing your .wine directory and reinstalling your apps.

share|improve this answer
Nothing to do with configuration, broken sound widely reported with upgrade. – Oxwivi Jul 27 '11 at 6:09
I also suggested it for the case that the upgrade somehow changed or required a different configuration. I'm not familiar with this particular upgrade, but I've dealt with Wine a lot before. – Barbarrosa Jul 27 '11 at 6:16
I backed up my wine prefix folder; used Synaptic to remove anything wine; and then installed 1.3.24. My sound seems to be fine now. I did not need my backup. Applications and configurations are as they were before. – Kevin Jul 27 '11 at 15:00

Here you can get older versions of Wine for Ubuntu(in .deb format):

share|improve this answer
Thanks I got version 1.3.24 from the link you provided. – Kevin Jul 27 '11 at 14:55

I see Kevin already got his earlier version but others might come to get answers so I'll post what worked for me :) This doesn't help you to revert to an earlier version of Wine, but it might enable sound in the current version. I also had no sound in wine after updating. On the audio tab of winecfg the audio test failed. I am using wine 1.3.28

The sound driver may not be set correctly in wines registry. You can set it to alsa by

From the terminal use wine regedit

Navigate to HKEY_CURRENT_USER\Software\Wine\Drivers

Open the Audio key and type Alsa

I hope this helps some!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.