Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Okay, so here's the deal.
I have Ubuntu 11.04
A green iPod nano 5th gen with video 8gb.
I'm fairly new to Ubuntu but trying to embrace it.
My major issue is, my iPod used to work but I filled it and tried to wipe it and start again.
When I wiped it, it left 3 songs? And still had over 1gb used of 'other'.
Whenever I tried to upload songs on to it it didn't work anymore.
It even went into disk mode and when I googled how to get it out of it, and did it, it told me to connect to iTunes to restore it.
So, I took it to my friends show has iTunes on Mac, restored it, took it home, connected it, didn't recognize it.
I put it down to being formatted for a mac.
Found a friend with iTunes/windows (there aren't many out there!) restored it but he put his flat mates music on it too to annoy me.
I now had Mariyah Carey on there. What if I died. I'd be found with an iPod and Mariyah Carey Christmas Album 2.
{: (
So excited to get home and change it, wiped all the crap off it, left the few albums that were good, disconnected it.
Everything is still on it, still says 1000+ songs, shows artists, albums, songs, but the music isn't on it apart from the few albums I left and neither is the artwork.
I'm usually OCD about my iPod, this upsets me greatly.
Luckily it has radio for the time being.
But I've tried GtkPod which used to work, Rhythmbox, Hipo, Floola and I'm about to try banshee.
I keep getting library errors.
I tried my friends iPod touch 1st gen to see if it was my iPod that was the problem. But that comes up with errors too.
Any help to a noob will be greatly appreciated.
I probably haven't supplied you with half the info you need so please write back and ask if you think you may be able to help.

share|improve this question

closed as too localized by Jorge Castro, Takkat, htorque, Bruno Pereira, fossfreedom Feb 4 '12 at 10:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Could you please be more specific? What do you mean by "Library Errors"? –  user6658 Jul 26 '11 at 23:23

2 Answers 2

I know for myself that formatting an ipod in a system and using it in another cause trouble. Formatting on mac, you can only using on mac. formatting on windows, you can only use it on windows. That is because each system use different file format to erase and rewrite the disk . If you can format it on mac, put music on mac, personalize it on mac, and do the same on windows, then the trouble really come from ubuntu. But if you can't do anything, no matter what OS you are using, then it is a trouble coming from the ipod, and it smells warranty

share|improve this answer

I also had problems with Nano 5th Gen iPod in Ubuntu 11.04. My experience was that Banshee and Rhythmbox did not cope well with it, and I had similar symptoms to you.

I tried floola too, and found it unreliable.

I did however find that gtkpod worked for me, though it took a few steps to get it right.

1) I used the version from the software centre (version 1), not the latest (version 2).

2) I had to follow the instructions here to set the firewire ID:

3) I also added a hashinfo file to the iPod, using the site at:

I don't know if the last step was essential. Possibly newer versions of gtkpod don't need it.

If your iPod is in a mess, I would get your Windows friend to restore it to a default (empty) state before you start. Some sites recommend iTunes copy at least one file onto the ipod to initialise the database. I found I had to copy a podcast episode to create the 'Podcasts' playlist that gtkPod needs to populate.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.