Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Here is an error I'm receiving while installing termkit:

npm ERR! Error: Not found: connect@'>=1.2.0- <1.3.0-'
npm ERR! Valid install targets:
npm ERR! ["latest","0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.1.0","0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","0.2.6","0.2.7","0.3.0","0.4.0","0.5.0","0.5.1","0.5.2","0.5.3","0.5.4","0.5.5","0.5.6","0.5.7","0.5.8","0.5.9","0.5.10","1.0.0","1.0.1"]
npm ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:313:10)
npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:306:17
npm ERR!     at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:134:7)
npm ERR!     at cb (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:31:9)
npm ERR! Report this *entire* log at:
npm ERR!     <>
npm ERR! or email it to:
npm ERR!     <>
npm ERR!
npm ERR! System Linux 2.6.39-02063901-generic
npm ERR! command "node" "/usr/local/bin/npm" "install"
npm ERR! node -v v0.5.3-pre
npm ERR! npm -v 1.0.22
npm ERR!
n    pm ERR! Additional logging details can be found in:
npm not ok

Any ideas?

share|improve this question
dependencies seem to be missing: Error: Not found: connect@'>=1.2.0- <1.3.0-' Do you ahve this installed? –  Thomas W. Jul 26 '11 at 18:57
I can't seem to find connect in repo or anywhere for that matter –  wisemonkey Jul 26 '11 at 22:07
I tried installing connect-proxy which was in repo but that didn't help, even I thought its dependency. I think it depends on which was a part of termkit but not anymore. –  wisemonkey Jul 26 '11 at 22:10

1 Answer 1

up vote 1 down vote accepted

ok so I've been buggin Floby (Termkit developer) about the issue. And looks like node v0.5.3-pre is not stable yet

So I went back to node v0.4.10 and it worked just fine. If anyone wanna try


git clone
cd node
git reset --hard 1b8dd65d6e3b82b6863e

Continue with these instructions that worked for me :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.