Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am Ubuntu 11.04 user ( Unity gui ) but i have an issue : I am working on an exercise for my university and i must have open a lot of pdf files , when i minimize them , they minimized in a group on unity launcher and it is not usefull this I would like to minimize them separately each window and not in groups . Is this possible ?

Thanks in advance!!

share|improve this question
add comment

2 Answers

I assume that you want each minimized window to get an own icon in the panel.

As far as my experience goes (and I greatly agree that this is a definite usability lack) unity itself is not capable of it. However another dock I used previously (avant-window-navigator) will do this for you and even display the pdf-preview images for each icon. Whenever I have such a task to do, I launch awn additionally. It also features auto-hiding and workspace seperation, so you can have all the open PDFs on one workspace.

Another feasible workaround for the specific instance would be to have tabs in the pdf-viewer, but until evince supports this (already requested), you would have to use a different viewer.

share|improve this answer
1  
no, actually, that's not necessary. You can use the Group and Tab compiz plugin to tab any windows. You can tab Firefox and multiple Evince windows, for instance. No problem. –  Jo-Erlend Schinstad Jul 27 '11 at 1:51
    
+1 for another good option, however the group and tab feature of compiz is not too intuitive and even seems unstable from time to time. –  rumpel Jul 27 '11 at 7:10
add comment

They actually do get minimized one by one. The launcher just hides it. I have an idea for you.

  • 1) Do all your PDF work on one workspace.
  • 2) Add a bottom gnome-panel with a window switcher. (The same one as we've used by default in earlier Ubuntus)
  • 3) If possible, make the panel only appear on your pdf workspace, or just make a keyboard shortcut so you can show and hide it quickly.

For a good result, you should delete the default upper panel. You can do this using gconf-editor, or you can just log out, choose Ubuntu Classic session, delete the upper panel and log back into Ubuntu with Unity. You then make gnome-panel start with the session (you can do that in the startup applications dialog)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.