Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently bought a new laptop (ASUS X53SJ) with these specs:

  • CPU: i5-2410M @ 2.3GHz
  • RAM: 4GB
  • GPU: NVIDIA GeForce GT 520M (512MB)

When I first booted into Ubuntu I got a message saying that Unity is not supported. So I believe, I am using gnome. The results of this command /usr/lib/nux/unity_support_test -p:

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: unable to create the OpenGL context

What is wrong with it?

Also gnome version 2 is currently installed. Am I able to use gnome version 3?

share|improve this question

3 Answers 3

You are using Ubuntu Classic (Gnome 2). This is standard as is the message that your hardware does not support Unity. This message is misleading. Your hardware is powerful enough for Unity when you have the proprietary driver installed. The message should say that you will need to activate the proprietary driver to use Unity.

The intention is to replace proprietary drivers with an open source driver. When that project is finished, then that message will mean what it says. Until then .....

Install the proprietary driver using the Additional Drivers utility:

You will get a message saying driver activated but not in use. Ignore this message. It is also faulty. The driver is in use.

Re-start and at login click on your user name and select Ubuntu from the menu on the bottom panel. That will run the Unity GUI.

Gnome 3 will be in 11.10. It is already in the Alpha versions. I am testing it. So, I know.

share|improve this answer
    
When I click at the "Additional Drivers utility" I get the message "driver activated but not in use" in both Ubuntu Classic and Ubuntu options..so what is wrong with it? –  Chris Jul 27 '11 at 22:07

In order to use gnome 3 you will have to either:

  1. use the gnatty ubuntu remaster (search ubuntu forums for it) - stable enough for me but, since it is only supported by one man is probably not the safest choice.
  2. use the not-even-in-beta-yet development version of 11.10 which is surprisingly stable for a development release but is still not ready yet - obviously - to be used if you don't want to spend time fixing it.
  3. wait for October and the official release of 11.10 (or at least September when it will be stable enough), which is probably the best idea.
  4. use the gnome-shell testing ppa if you don't care about unity. This one isn't stable yet either.

As for the error you get above, I got the same one today I don't know which one of these fixed it, but I did both of these:

  1. Reinstall unity and nvidia-current
  2. Force unity to start by changing the file at /etc/environment (gksudo gedit /etc/environment) by adding this"UNITY_FORCE_START=1 at its end
share|improve this answer
    
Those are some bad advice. It's not a very good idea to use unstable software. I mean... We've been using Gnome Panel for seven years. With 11.10 you'll get Unity 2D as a fallback and it's really quite good. It's better to just wait a couple of months and get stable and polished software with all the bells and whistles. –  Jo-Erlend Schinstad Jul 26 '11 at 23:15
    
I'm pretty sure that you are unable to read what i wrote. I gave all possible ways to get gnome 3 , exactly as he asked. I gave warnings mentioning that it is unstable software, it's not like i led him to the slaughter. I even made it very clear that the 3rd option (==waiting) is the best one. as for the unity part, it is rather good advice. I mean, look at his hardware, it's not like it's not powerful enough to run it. He should force unity to run and file a bug report about the mistaken blacklisting of his card... –  Chriskin Jul 27 '11 at 4:38

If you want to, you can install the package named 'unity-2d' from the Ubuntu Software Center:

It aims to provide the same features as Unity, but without the need for graphics acceleration.

Or you can wait until October and upgrade to 11.10 which quite possibly will enable you to use normal Unity, but also comes with Unity 2D as fallback by default. Of course, you might benefit from testing development versions of it and reporting bugs.

share|improve this answer
    
He never asked for unity-2d. His hardware is powerful enough to run unity 3d, and he should use it. An X error shouldn't make him have an inferior experience - he should just work around the X error. Having passed though the same problem and since i have a graphics card of the same series as his i propose what i said below : wait until october for gnome 3 and fix the X error by reinstalling the graphics card drivers. –  Chriskin Jul 27 '11 at 4:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.